Results 1 to 9 of 9
  1.    #1  
    Hello there, I'm wondering if anyone can help me with a problem I have with my Treo650. I just bought it from a friend, who said he tested itas a PDA and worked fine, but tested it as a cell phone. Well, heres my problem: I just acquired a SIM card and tried to use it, and it works but just for a couple of minutes, at the end of wich time the phone resets itself. I had the phone and tested it myself as a PDA for about a week and it never did anything like it until I tried to use it a a cell phone. The thing is, that it happens only when the Phone mode/application is on . then I checked the error registry from the Treo and this is what it displays:

    A reset was caused on
    Day/Moth/Year at HH:MM while
    running "Phone":

    Line:609, CcpDataSend
    returned error = 0x0001
    (FW crash?)

    It says all that. Let me add that I did a hard reset to delete all the third party applications, and it still does the same thing and display same message.
    I also downloaded the update from and my Treo is still the same. Is there something I can do to fix the problem and get it to work??
  2. #2  
    Try upgrading firmware only (or downgrade then upgrade). Check if it is the right one for your device (GSM/CDMA). If it isn't the right one than it is bad. Otherwise it is probably a hardware-related issue.
  3.    #3  
    I've already upgraded the firmware to 1.20 upgrade on How can I downgrade it to later upgrade it again?????
  4. #4  
    this might be stupid but have you checked the Sim tray? Palm had problems with their first sim trays being too loose and this let the sim card move around too much and when that happens the phone will reset... try checking out your sim card and checking if there's a little ridge in the middle, if not try doing a search here for sim trays and u should be able to find a link where Palm is replacing the sim trays... hope this helps.
  5. #5  
    Hi.. i had the same issue.. turns out its a hardware problem.. palm replaced it for me. I was using a gsm unlocked.. same error msg only when wireless mode on.. get it changed...
  6. pxcz's Avatar
    1 Posts
    with older firmware is this error message interpreted as well-known "HALRadioAcDc.c, Line 441: Host wake not asserted in time" .. and yes, it's a (serviceable) hardware error ..
  7. #7  
    pxcz, which ultimately means returning the phone?
  8.    #8  
    So it's a hardware problem?? that's bad luck. Well, I think I'll have to get it replaced. Thanks a lot for your help anyway.
  9. #9  
    Sometimes HARD RESET is not the exact solution, TRY SOFT RESET 3x! We've expericed a lot of problems with treo 650 but this solution works!!! Theres no harm in trying this. I'm working for Earthlink Wireless & We are also the Tier 2 Technical support of Helio.

Posting Permissions