Results 1 to 9 of 9
  1.    #1  
    I've just started having a problem with my GSM Treo 650 (purchsed from AT&T but now unlocked). I tried searching but I am getting some errors from Treocentral when I search for Treo not charging.

    All of a sudden the phone won't charge. I've tried with 2 different AC adapters plus a car charger that all previously worked. I took the phone apart but could not see anything obvious around the connector where the power goes in. Everything looks clean and the connector seems to be properly soldered onto the motherboard.

    Two questions:

    1.) Has anybody had this problem and has been able to resolve it?

    2.) Has anybody seen a charger for the battery alone so I could take the battery out and charge it by itself.
  2.    #2  
    Also, where is the best place to get a new motherboard if this one happens to be fried? I didn't see any obvious problems with the connector. A couple of days ago I was using my phone to navigate on a long road trip (using a BT GPS and Mapopolis) when I noticed the phone was very warm. Perhaps something happened during that time that now the charging circuit doesn't work anymore. The phone and PDA work fine, it just doesn't charge the battery.
  3. Camel's Avatar
    318 Posts
    Global Posts
    319 Global Posts
    dead battery perhaps?
    It can happen. I had one like that for my old mpx200 phone.
    Made this just for fun...I'm Kermit

  4. #5  
    It could be a dead battery, but you'll usually notice a gradual decline in its life before it just goes kaplunk on ya. If you know anyone that has a Treo you could always try using their battery(or getting one of the extended ones, which I highly recommend anyway).
    Why are ringtones always such a big issue? Don't people realize that they're obnoxious!? And why the Nintendo 'Wii'? What th-!?
  5.    #6  
    Thanks for the link to the charger. That's exactly what I was looking for.

    The battery is still alive. It had gone down from normal use, but the phone still powers up and works normally. The problem is that when you plug it in, it doesn't beep and the LED doesn't turn red to indicate charging - it just keeps blinking green, as it normally does when the phone is connected to the cellular network. The battery doesn't charge up at all over several hours. This symptom persists across three different chargers.

    However, I guess there could be some other issue with the battery that results in this symptom. I'll see if I can go to a store to try out a different battery. Otherwise I'll have to resort to an external charger. The phone is out of warranty by about two months and I'd rather wait for one of the new models before replacing this one.
  6. #7  
    Car chargers are quite capable of screwing up a battery.
  7. #8  
    where are you located...
    maybe find a another 650 user local....
    hey actually put one of the treo user maps to use....
    i was going to paste the link but....
    insertion will love this....hmm i can't think of what to search for...
    I think the next post someone will point it in the right direction
  8.    #9  
    Well I went to a Cingular store and tried another battery with one of their chargers and the phone still won't go into charge mode. I am just going to buy an external charger for now.

    The current set of phones just doesn't quite do it for me and I am sure I will want another one within a year or so. I did like the Cingular 2125 and 8125 phones running Windows Mobile. I feel like PalmOS is on its way out so I'll likely switch OS (even with a new Treo). However, I'd like my phone to support UMTS for faster data throughput. I also understand quadband UMTS phones also work in Japan.

    I am not impressed with the durability of the Treo. This is the first cellphone to die on me after owning a half dozen different ones, most for longer than the Treo.

Posting Permissions