Results 1 to 5 of 5
  1.    #1  
    (EDIT: this was my original plea for help: solution is posted below)

    I'm pulling my hair out here, because I'm trying to get BT DUN working before I install the rest of my software on this phone, and it's stumped me for the second full day now:

    I've got a Cingular branded Treo 650 with the latest firmware version (1.17 A) and I've been searching through all the forums and sites trying to get my powerbook to use the damn thing as a modem. NO success whatsoever (actually had better luck BEFORE the update; it connected but didn't exchange data) and I'm getting the same problem each time:

    I can't get the phone and the computer to talk to eachother when the phone has BT DUN activated in the BT prefs. When attempting to pair the two, the computer will see the treo, and then hang indefinitely on the next screen ("gathering information about your device..."). The only way I can get them to pair successfully is with the BT DUN option off, and this doesn't give me any services to select (which i gather is necessary).

    thinking maybe the firmware is corrupt, I've tried reinstalling the Cingular updater without success, which I'm sure is because it's checking the version and seeing that I already have it. Can't install the Shadowmite due to repeated "system error"

    Pairing without the BT DUN active leads to errors when attempting to use internet connect over BT (understandable) and turning the option on after pairing leads to no device communication whatsoever.

    What can I do here?
    Anyone else had this problem?
    do I have a bad phone?
    Is my computer's bluetooth software screwed?
    Is there any way to reinstall an update or firmware on the Treo (without a card reader)?

    Any help you guys can provide is much appreciated, as I'm about ready to throw the phone out a third-story window and drive over it a few times.
    Last edited by keyboardist; 04/09/2006 at 07:06 AM.
  2. #2  
    I have used DUN on my G4 powerbook (10.3.9) with DLink BT120 adapter. The 650's firmware was 1.28 / 1.13. What I had to do was start from scratch each time:

    - Delete any previous pairing (important)
    - Soft reset the phone (just in case). Then turn the phone on
    - on the 650 BT menu, set discoverable to off, Dial up networking to on
    - Pair the phone with the computer in the normal way.

    When it is connected you should see an icon of a laptop in the top right corner of the 650's screen

    To get the phone working again normally afterwards, I think I turned DUN off on the BT menu, then turned BT off and then back on again on the same menu - sometimes it would hang and I would have to reset the phone.

    Good luck! It is certainly worth the effort.
  3. #3  
    PS Sorry, can't remember if I had discoverable to to on or off - you should try both. Also you need to make sure you mobile phone service provider has data services available on your phone connectionr.
  4.    #4  
    Ok, I half-stumbled across the right combination of settings and now have a working EDGE connection. Here's what I did:

    Paired the phone to the computer (g4 powerbook with OSX 10.4.6) with the Treo's BT settings as such:

    Discoverable: ON
    DUN: OFF

    Then, to get the computer to see it as an internet source, I had to change the Treo settings to:

    DUN: ON

    And go into the bluetooth prefs on the mac, highlight the phone, hit the "configure" button, and check the "use this device to connect to the internet" option

    It is important to note that this did NOT show up when I first paired the treo, as I could not get the treo to successfully pair with DUN active. I had to first pair the treo in normal BT mode, then switch it over and configure the BT settings on the mac. I think this was the key to getting everything working.

    Then, using the the Generic 3G CID1 modem script (downloaded from here: and connection settings as follows:

    Account name: WAP@CINGULARGPRS.COM
    Password: CINGULAR1
    telephone Number: wap.cingular (NOT the *99***whatever one)

    I was able to successfully connect using EDGE here in Los Angeles, at a tested speed of 114.3 K (this is through the PDA connect plan that cingular offers for $40/mo with a Treo)

    Whew. Hope that helps some of you other people; it took me months.
  5. #5  
    Glad it worked. Why does it have to be so difficult, though?

Posting Permissions