Results 1 to 12 of 12
  1.    #1  

    I was wondering if any of you had any experience with getting the 650 to work with T-Mobile.

    I had a 600 that I bought that was AT&T, and was able to put some transfer software on it that made it work with my Cingular when I was with them, so I thought the same would work for my new 650, and it worked for one call, but now all it does is reboot about 3 seconds after the "T-Mobile" sign comes on, and the green light (indicating I'm connected to their network) comes on.

    Any ideas?

    Thanks in advnce,
  2. #2  
    Have you tried backing up your device then trying again after a hard reset?
  3.    #3  

    Yeah, unfortunately that didn't work.

    I'm trying to find the software I used on my 600, and see if there's similar software that's out there that will enable it for T-Mobile.

    I'll post if I find anything.

    Thanks thought, I appreciate the reply.

  4. #4  
    i was using T-Mobile on my treo 650 when i visited the US last february... traveled from texas to arizona to vegas and california... never encountered any problems...
  5. #5  
    I have been using Treo 650 with T-Mobile for more than a year. Never used any "transfer software" and never got into a reset loop.

    Does the phone work with another SIM from another carrier? If that works, try a different T-Mobile SIM from a friend or from a store. Since you already tried a hard reset, it has to be either the SIM or the hardware. That's what I think.
    Prio Treo
    Unlocked Unbranded Treo 650 on T-Mobile-T-Zone
  6. #6  
    Same here-Treo 650 since last August. I simply took the same SIM from my Nokia 3650 and plugged it in. Only trouble I had was getting T-Zones to work; required a call to T-Mobile support
  7. #7  
    Where did you get your 650? If you got it from Cingular, then you need the unlock code from Cingular to allow it to use a T-Mobile SIM. There is no software you can "load" that will eliminate the SIM lock. If you are using an unbranded GSM Treo, then there should not be anything you have to do.
  8. jberger's Avatar
    241 Posts
    Global Posts
    244 Global Posts
    You'll need a recent SIM card to make it work. When I first received the 650 (unlocked GSM), I tried my existing SIM for TMobile it would not work. Had Tmobile replace the SIM and everything worked fine.
    I'd update the SIM, then try a hard reset and see what happens. If it doesn't work then, you have a bad phone or a locked phone.
  9. #9  
    I had problems when I switched to an unlocked 650 and Palm and T-Mob support couldn't figure it out. I went to the local T-Mob outlet and they made me a new SIM and all was well. It was an easy fix. You might try that.
  10. #10  
    I am also using 650 on T-mo, with $19.99 Internet VPN (the old one).

    Just several simple questions,
    1. Is your 650 unlocked? - Since T-mo doesn't carry 650, you either get one from Palm or unlocked Cingular.

    2. When did you first got your SIM? - As said before, old SIM may cause problem.

    3. Did you sync with your old Hotsync ID (the one from 600?) - A known fact, old 3rd party softwares are trouble makers. Check Palm KB for this issue.
  11. #11  
    I had very little trouble until I loaded the 1.20ena firmware. I am back on 1.43 hoping for the best.

    1.20 would freeze my data connection until:

    A hard reset or
    Called TMO and had them reset my connection.

    It starts when I get a dropped network or reset during a data session. Never did that on 1.43.

    Nearly 50K minutes since October and happy.


    Treo 180 --> 270 --> 600 --> 650 --> 680 -- Pro ( )
  12. #12  
    Quote Originally Posted by computerfixitguy
    1.20 would freeze my data connection until:
    A hard reset or
    Called TMO and had them reset my connection.
    Derek, try this. Pull your SIM out, wait for 1-2 min and turn on the phone. It will reset your internet connection. Works for me.

    I have been having this problem for quite a while. If I move from my house to my office or the other way around, I need to do this in order to get the connection. Called T-mo and nobody seems to know what is wrong. Pulling the SIM is the only easy fix now.

    Not sure if it's 1.20 related. And don't know how much longer I will wait till jumping to another carrier.

Posting Permissions