I'm a newbie here, and just got my Treo 650 the other day, and I'm stuck in a rut, and I've lurked the discussions and can't seem to find anything similar to my issue, so I thought I'd ask you all and see if anyone has any recommendations.

I just got an unlocked (I think) Treo 650 from Cingular as a "we're sorry" type of thing from Cingular, as I used to be a customer of theirs (I'll post this one somewhere by itself in the appropriate place - it really is interesting), and I've been checking it out, installing and what not, and so far so good. Not!

As soon as I went to put the power into the sync cable, the device froze up on me, and the only thing that gets it out is a hard reset.

Ok, did that, and successfully repeated the problem, so there's consistency. Next, I called Palm, talked to some girl named Angela, who was about as rude as they come (I couldn't get a complete sentence out to save my life!), who walked me through (eventually) a few things, hard reset being the main event. She passed me on to Cingular, who told me that they couldn't do anything because I'm no longer a customer of theirs, so ultimately I'm going to have to call back the person who sent me this phone, who's in the office of the president for Cingular.

Anyway, I saw some posts in here about the ROMTool, and thought I'd give it a try. I backed up my existing setup, uploaded the ROMTool, and now I'm in a constant reboot. I tried doing a hard reset, held the power button down, pressed the up button, all of that, all to no avail, so I reloaded my existing setup back on, thinking that might have nudged it loose and set it free. No such luck.

So, I'm not sure what to do, other than call this guy back, but before I do that, I wanted to ask you all if anyone has run into the constant reboot thing with the ROMTool before, by chance.

I realize the ROMTool thing may not be the place to post this, but my main issue is the device freezing up when I put the power cord into the sync cable, and I was wondering if any of you ran into this, and got passed it.

Oh, and I did the Cingular updater as well (1.17-CNG), and that just hung right at the place where I put my power cord in to run the setup of the updater.

Sorry if this is confusing, but I tried to get this all out w/o writing a novel and putting everyone to sleep.

Any responses (having to do with the issues presented here) would be greatly appreciated.

Thanks again in advance,