I have had no problem at all with my email sync since I got the 650 last June, now I get an error message and it wont sync email or calendar. I use active exchange and it syncs with an Outlook Web Access work account, or atleast it use to. Now when I try to sync it shows connection taking place and "syncing email" comes up then I get an error as follows:

2107 1509 Server
returned error for last
command. Status:5

Have tried:
-deleting email account and setting up new one
-soft reset and warm reset
-transferring emails in my work box to a temp folder (incase there was an email causing the problem)
-Talked to my IT guys-no clue but still looking into it
-Talked to Sprint-tried a few things but no luck

Trying to avoid hard reset partly because I don't think it will help either.

Everything was fine until I travelled out of town to Chicago (from Michigan) firt attemt to sync email got error message. Also, recently activated blue tooth option for new car hook up.

Any suggestions would be appreciated.