Results 1 to 5 of 5
  1.    #1  
    For the past 2 years I've used the SD card in my Treo 600 with no problem. Today when I put the card in, it stops after going in 4/5 of the way. There's no familiar firm insertion feel, and there's something blocking the way of the card going in.

    I want to say it's the "ejection" mechanism that's blocking the way, but I'm not sure.

    Can anyone suggest a fix to this problem?

    Million Dollar Bills, anyone?

    <a href=""></a>
  2. #2  
    I hate to ask this, because I don't want to seem insulting, but sometimes the most obvious thing is easiest to overlook. You are putting the card in with the label towards the back of the phone, aren't you?

    If that's not the issue, I'm afraid I don't have any suggestions to offer.
    Bob Meyer
    I'm out of my mind. But feel free to leave a message.
  3. #3  
    And let's be honest. There really is nothing quite like that "familiar firm insertion feel."

    Other than making sure the card is not upside down, or backwards, have you tried looking into the slot to see if something is lodged in there? Card damaged? Or it could be a faulty ejection mechanism. The Forum That Asks, "Are You Not Entertained?"

    Remember: "Anyone that thinks the Treo should just work right out of the box, shouldn't own a Treo..."
  4. #4  
    Yeah, there's probably something lodged in there. Check it out with a teeny tiny flashlight and some pliers.
    Why are ringtones always such a big issue? Don't people realize that they're obnoxious!? And why the Nintendo 'Wii'? What th-!?
  5.    #5  
    Thanks for all the suggestions. I looked into the SD slot and compared it to my wife's Treo 600 SD slot. In mine there was a little light colored piece-of-something in there. I was able to remove it, and the SD card worked again!

    The culprit piece was a broken off piece of plastic from somewhere inside the SD slot.

    Thanks again for the help!

    Million Dollar Bills, anyone?

    <a href=""></a>

Posting Permissions