Results 1 to 17 of 17
  1.    #1  
    I have a Transcend 2GB SD card.
    It no longer formats.

    It will format from the CardInfo app., and then accept data and application moves from the internal memory, but when you pull the card, and reinsert it, it wants to know if you which to reformat the card or cancel.

    Hit the format button here, it wipes the card, and it is once again unreadble.

    This happened after I tried to load some mp3's with the Missingsync.prc. After I mounted the SD card on the desktop, and tried to drag some songs to the memory card, the card went kaput.

    If I format the card with the CardInfo app then I can format it as well on a PC or MAC. But everytime I put it back into the 650 it wants to reformat it again. When I hit format, it hangs saying formatting... and never finishes.

    So, I can use it still on a Mac and PC but not on my Palm.

    Any ideas here?
    The card is rendered useless. I might add that the MissingSync.prc has always caused problems similar to this but not this drastic.

    Thanks in advance
  2. #2  
    What does missingsync.prc do?
    Treo 300 (x2), 600 (x3), 650 (x6), 700p (ROM'd to 755p)
    My Custom Black-Tie 700p
    Sprint, 750 AT, Unl N/W @ 7pm, Unl Roaming/Power Vision/Pix/Txt/M2M, $46/mo.
    Lost Your Treo 300/600/650/680/700/750 CD? Download them here.
  3. #3  
    I've been having problems with my 2 gig SD card as well, only mine can't be read from my laptop for some reason. I have to use CardExport which basically turns my Treo into a card reader, but is WAY slower than what I'm used to.

    Maybe the MissingSync file is the problem? Maybe you could test your card out without it?
    Why are ringtones always such a big issue? Don't people realize that they're obnoxious!? And why the Nintendo 'Wii'? What th-!?
  4. blee4's Avatar
    52 Posts
    Global Posts
    380 Global Posts
    MissingSync PRC allows you to mount your SD card on a mac as a drive when you have the cable plugged in to it
  5. #5  
    When you insert the card and the Treo asks to reformat:

    - don't answer
    - soft reset instead (with the stylus)

    After reboot, you 'll get your data.

  6.    #6  
    When I do this, the soft reset, it asks again to reformat. Ignoring this again, the card does not show up at all. ???
  7. #7  
    I had that same problem. But, I eventualy gave up and bought a 4 gb sd card. For some reason, my treo still reads it as a 1.7 gb card not 4 gbs? would any know how to overcome this problem? I don't want my 4 gb card to go bad like my older 2 gb card. Its a weird formating issue
  8. #8  
    650's have a 2GB limit on SD cards unless you upgrade the Treo to FAT32.
    Treo 300 (x2), 600 (x3), 650 (x6), 700p (ROM'd to 755p)
    My Custom Black-Tie 700p
    Sprint, 750 AT, Unl N/W @ 7pm, Unl Roaming/Power Vision/Pix/Txt/M2M, $46/mo.
    Lost Your Treo 300/600/650/680/700/750 CD? Download them here.
  9. #9  
    When I do this, the soft reset, it asks again to reformat. Ignoring this again, the card does not show up at all. ???
    I'm sorry this didn't work for you. This work very well for me each time, and I have done this for several months.

    - I did format the card using my PC
    - Then I insert the card into the Treo... it asks to format the card
    - I don't answer and soft reset using the stylus
    - And after the reset my card is available.

    The card works then perfectly until I remove / reinsert it. I then have to perform a soft reset again.

  10. #10  
    Has it worked until recently or did you just buy it?

    2GB cards are very hit-or-miss, and they seems to either work perfectly from the start, or never work correctly at all. Even identical models of identical brands will work in one poster's Treo but not work in somone else's. I had all kinds of problems with the first 2 that I got (Patriot and ADATA). Eventually I got a basic blue 2GB Sandisk and it has worked fine.

    Try another card. If you live in the US, Circuit City has a really good deal on 2GB cards and they have a no-questions-asked return policy. Get the basic card -- many feel that the high-speed cards are less compatible with the 650.
  11. #11  
    I'm returning a Sandisk Ultra II 2GB card that I couldn't get to work. I'm reasonably sure that it was a bad card, and not a Treo issue, though. I tried it in two different card readers, one of them a Sandisk product. A format in Windows or DOS would complete normally, but the card would show no free space. The Treo would recognize the card when first inserted, but it would vanish if I switched apps or attempted to format it.
    Luckily, the Pricegrabber storefront I purchased it from is very responsive (replied to my e-mail in under an hour!), and is already sending me a replacement.
  12.    #12  
    My card worked fine until I tried to mount it with the Missing Sync mounter, and then the Missing Sync mounter tried for a hour flashing its green menu bar up and down. Then I removed the card turned off Missing Sync mounter and it has been wacked ever since. It will format on my MAC and PC and can be used as an SD card on either platform. However when reinserted to the Treo it always asked to be reformated and cannot be read even when you choose the reformat option, in which case it does not show up.

    It seems that if you can format the card for other platforms, the card is probably ok, but how can a piece of software wack out the hardware of an SD card?
  13. #13  
    I had a similar problem with the Ridata Pro 150x 2gb SD card. I formatted it with the Treo 650. Loaded it with apps but upon ejecting the card and later reinserting it, the SD card was no longer recognized and asks to reformat it. I did try the soft resets as posted in some forums but to no avail. I even tried formatting it in my digital camera but the problem of the card not being recognized kept happening.

    My last resort was to format it under Windows specifically for FAT (Fat16) and NOT FAT32. It solved my problem and the problem never cropped up anymore.

    I hope this suggestion helps.
  14.    #14  
    Yes I can still reformat it with the Treo Card Reader app., load it with applications, but upon ejecting the card and reinserting it, it asks to reformat it. Soft resets do not work.

    I tried it in my Windows laptop and it does not even see the card, so Fat16 reformat is not a possibility. Also tried reading it with my MAC powerbook, it does not see it either.

    I think its time for the garbage can. Only got the card two months ago. This all happened when I tried to use the Missing Sync mounter.
  15. #15  
    Don't give up. Just got wife's Treo 650 VerizonWireless yesterday and did not buy SD card yet. Fairfax VA and Alexandria VA
  16. #16  
    Here's a quandry for ya. I recently bought a 4g (without doing any research to see if the Treo 650 is compatible. DOH!) SD card off ebay for a really cheap price. When I insert the SD card into my card reader and on my computer it posted as a FAT32 4g removable drive. I then insert it into my phone and it askes me to reformat it. I reformat it and its now a 2g SD card. My computer reads it as a 2g SD card. If I try to reformat it on my computer it is still a 2g SD card. Did I screw up the SD card permanently? Can I ever get it back to 4g? I was thinking of altering my ROM on the Treo 650 so I can read 4g cards but I would need they card to be a 4g card again! Any advice?
  17. #17  
    How do you reformat the 2gb card to FAT16 manually?

Posting Permissions