Results 1 to 14 of 14
  1.    #1  
    I have a user with a Verizon Treo 650. I set up their Versamail ActiveSync. Everything seemed fine as it was working from 2/9/2006 thru 2/13/2006. On Monday morning of the 13 she started getting fail messages on the auto-sync.
    Error Message reads.
    There was a problem syncing messages. Can't connect to server. Please check your network or server settings and try again.
    Details: AirSAMStateMachine.c 435 103

    I myself have a Sprint Treo 650 and it is working fine. I can set it up to use my problem user's account and I will get the same error. This tells me it is something to do with her account.

    Does anyone have an idea what could be causing this problem?

    System specs.
    Server 2003 Enterprise
    Exchange 2003 Enterprise
    VersaMail 1.3

  2. #2  
    I have a very similar issue -- isolated to one account. Just want to keep this thread alive if someone comes up with any solution.

  3. #3  
    Check this out and let me know if it applies to you:

    Also, try this:,kb=PalmSupportKB,CASE=obj(36541),ts=Palm_External2001

    Have you also tried a soft reset? warm reset?

  4. #4  
    Further Review.. Performed soft and warm reset..
    I configured the same treo 650 with someone elses network credentials and it sync'd just fine. Went back to the user in question network credentials.. error comes back. Recent incidents service pack 2 or outlook 2003 and post fixes (all). (seems to be mailbox/user specific.
  5. #5  
    Are you using Exchange?
  6. #6  
    aplogies..Yes, Exchange 2003 Standard Service pack 2
  7. #7  
    I have the same exact issue and configuration as Donthein. Exch 2003 SP2, Treo 650 1.17. Other users are okay (on the same handheld). Only one user has problem. Had done soft and hard resets. Even tested the handheld on another/different Exchange server (it works fine).

    Anyway, on the problematic user -- he has 3.2GB mailbox size. There are many sub-folders, but the Inbox only has 552 items (which I've already moved out, tested and failed, and moved back in). I'm tempted to .PST his entire account, then delete it from the Exch server, re-create it, then re-import the .PST back. But I'm hoping there's some other simple fix.

  8. #8  
    It was suggested I do the same thing. The mail box size is almost identical to Oryxtek's problem child.

    I guess I can run eseutil.exe against the exchange database to see if there are any issues.. Going to try something first.. I will let you know how it comes out..
  9. #9  
    Please do keep us posted Donthein on that "other something" you're going to try first. Thanks!
  10. #10  
    I am experiencing the same error AirSAMStateMachine.c 435 103 error described by donthein and Oryxtek. Did either of you solve the issue you were having yet? If so, how and what is the cause?
  11. #11  
    Quote Originally Posted by jalboum
    I am experiencing the same error AirSAMStateMachine.c 435 103 error described by donthein and Oryxtek. Did either of you solve the issue you were having yet? If so, how and what is the cause?
    I was having a similar problem - AirSAMStateMachine.c 435 4626 -

    I followed the information at:

    or for short

    Carefully follow ALL the steps, not only downloading FileZ to allow you to delete the Versamail databases from the Treo, but also especially renaming Versamail folder and the Backup folder on the users PC. You can also rename the User folder if it comes to that, but you probably won't need to.

    This worked for me, so I would encourage anyone having this problem to give it a try.

    Good luck, and if this works for you, too, please post your success back here.
  12. #12  
    Had a user that was receiving the AirSAMStateMachine.c 435 103. When you look up the error on the Palm support web site it only states that 103 is "data too large". tried many things and he continued to receive the error. If I set up his account on another Treo 650 the same error would occur. Other user accounts set up on the same Treo 650 worked fine.

    I finally looked at his Inbox and it turned out he had several hundred subfolders. I transferred over a hundred subfolders to a PST file and once the subfolders were moved he was able to synch again on his Treo. I then moved the folders back to a folder under his mailbox not as a subfolder of the Inbox and I was still able to synch.

    I thought I had found an article that if the Inbox had more than 325 subfolders that they would receive that error. Of course I could not locate the article again but in this case he had many more then 325 and once I got the subfolders to under 300 it worked fine.

    Hope this information helps others.

    Last edited by KMan70; 05/25/2006 at 04:39 PM. Reason: spelling corrections
  13. #13  
    This problem also exist on 700p. I works for a while for one of my user who has 1,000+ folders and 10GB mailbox. Now his mailbox is around 11GB and Treo 700p starts giving out that 103 error too.

    This sucks. Why Treo has to check subfolders and mailbox size. All user wants is the get inbox mails, don't cares about sub folders..
  14. #14  
    Almost the same problem here on a Treo 755p, but just different code. I'm getting AirSamStateMachine.c 1913 103 for one user's account. Same account gives the same error on a different phone, too. Other Exchange users have no problem with their EAS on Treos.

    I used ExMerge to exported his mail into several .PSTs today. His mailbox is 3.5gb and it has thousands of folders. Created a new exchange account, EAS worked for the first time. Then I started importing a 1gb .PST into the new Exchange account, as soon as the import finishes, I tried EAS again. Same error as before. So it doesn't seem to be the mailbox corruption that's causing the problem, I really think too many folders is what's preventing the Treo to sync and throw out this error.

    Prior to ExMerge step, I tested his account on a windows mobile 6.1 device (HTC Touch), it took 20-30 minutes to connect initially. Then it worked on and off.

    I'm not if I'm reading the number of his folders in outlook correctly, 6100. It's hard to believe it. I right clicked on Inbox, Folder Size, then it showed some numbers increasing from hundreds into thousands, it took a seconds before the window deplayed the folder size. Was the number I saw the total number of folders before the folder size window was displayed? I'm not sure. But I do know the user has easily a few hundreds of folders.

Posting Permissions