Results 1 to 7 of 7
  1. bigwalton's Avatar
    65 Posts
    Global Posts
    93 Global Posts
    With the prospect of a 4GB SD card working on my Treo (iTreo Nano here I come! ) with the new Fat32 hack dealio, I've been doing a lot of reading on here about custom ROMs... unfortunately though, it appears that Shadowmite's legendary ROM tool is PC-based and when I downloaded the Mac tool from his site (which he says hasn't been updated in a while) and went to start learning how it worked, the instructions called for files that weren't in the ROM image that I had grabbed to start with.

    I'm having a lot of trouble finding anything Mac-specific about how to customoize ROMs. Anyone know of a good thread (searching is turning up little) or have ready instructions? Alternatively, has anyone successfully used the Mac tool that is on Shadowmite's site: Treo_650_ROM_Customizer_0.3 to make ROMs in Tiger?

    I really want to make it exactly how I want it rather than using someone else's ROM. It's also just something I want to learn to do

    Any help is appreciated...
    Treo 755P
  2. #2  
    I tried to do the FAT32 custom ROM with my Verizon 650 and a Mac this past Sunday and failed miserably. I think the tool for the Mac was fine. I think my error was to add to the ROM some apps that were not on the "safe" list. Unfortunately, I messed up so royally that I fell into a reset loop and couldn't even break free with a zero-out reset--and that requires some acrobatics to accomplish!

    I got my replacement 650 today and I am torn about trying again. I'd love some instructions from someone with a Verizon 650 and a Mac, but that might be too much to ask. If my pioneering spirit wins out and I try again, the only thing I think that I will do is the FAT32 thing and remove a couple of the known safe apps that I don't use. I'm just going to keep it simple.
  3. bigwalton's Avatar
    65 Posts
    Global Posts
    93 Global Posts
    Quote Originally Posted by OriginalSim
    I tried to do the FAT32 custom ROM with my Verizon 650 and a Mac this past Sunday and failed miserably.
    Can you post a link to the .zip that you used for the base ROM? I just want to compare it to what I was hoping to start with for my own Cingular ROM. I didn't have the "ROM" folder that the tool's instructions mentioned was needed in the one that I pulled down...

    It would me much appreciated.
    Treo 755P
  4. #4  
    Well, I failed again. Guess I'm not the geek I so want to be. To Verizon's credit, I got my second replacement unit yesterday. Lesson learned. No more ROM customizations for me.

    In my frustration, I trashed all the bookmarks and files I used. I just tried to find the ROM I used again for you, but my heart isn't in it. I originally found it through a link on a message board or maybe a link in the master file list PDF. It wasn't easy to find. Now I can't remember. In the trauma of it all, I've blocked it out. The page I got the Verizon ROM from had different Verizon ROMs to use depending on what apps I wanted to remove. There were only Verizon ROMs on the page I saw and I wasn't looking for other carriers. I chose to use the full version of the Verizon ROM so that I could manually add and remove the apps. The second time around, I was sure to only add and remove those indicated on the master file list.

    There's one thing that I do remember that might help you, if you still want to try fior yourself. Running the script kept generating an error. I searched for the error message on the boards and found (the second time around) that in order for the script to work without generating an error message, you need to install the AppleScript addition called Xtool.osax, which you can Google and get for free. That did allow me to use the script without error and everything seemed to work as I had expected. It was just that after the last hard reset at the end of the process it fell into the reset loop of death that even a zero-out reset can't resurrect.

    If you can resist the temptation, I think you'll be better for it. Of course, if someone advised me that way, I probably would still try. Good luck!
  5. bigwalton's Avatar
    65 Posts
    Global Posts
    93 Global Posts
    I'm on Cingular, so it wouldn't have helped to have that ROM anyway, thanks.

    Funny timing. I was notified of your post IMMEDIATELY after getting to the error I think you're mentioning. It came up right after choosing the files to delete

    I'm starting with a ROM that's REALLY close to what I want and that people have said works. I just want RealPlayer off of it along with the clock and extra languages. I don't really want to add anything, I'm just sick of seeing Versa, Real, GetGood and Xpressmail on there when I won't ever use any of them.

    Maybe I should just go with what I have that's already tested and deal with looking at some, but fewer, of the apps I don't want in there.

    Anyone used this customizer successfully on a Mac with Tiger?

    Also, I have found the extra scripting thingy, where does it need to go to be "installed".
    Treo 755P
  6. #6  
    Yup, the error you saw is the one I was referring to that led me to find the tip on the script addition.

    Here are the instructions for installing the AppleScript addition:

    To make the Scripting Addition available to only yourself, you should install it into the "ScriptingAdditions" folder in your "Users > UserName > Library" folder. If this folder doesn't exist, you can create it. However, make sure it's spelled "ScriptingAdditions" with no spaces.

    To make the Scripting Addition available to all users, you should install it into the "ScriptingAdditions" folder in the root directory's "Library".
  7. #7  
    I hope we get mmastrac's ROM update tool - that looks to be the easiest and safest, and he's asking for Mac beta testers.


Posting Permissions