Results 1 to 6 of 6
  1. NeoTreo's Avatar
    39 Posts
    Global Posts
    100 Global Posts


    I've checked past postings and there were many postings on how to format a card via DOS but my new 2GB SanDisk Blue card labeled as 2.0 GB only has 970MB per my PC via a card reader. I tried formating it via DOS and the capacity reads ony 970MB. The Treo 650 also reads it as 970.5MB and when I try to format it the card is no longer recognized as inserted. The card's device ID is "SD01G.... which I think indicate 1GB

    Did I get ripped and have a 1GB card with a 2GB label?
  2. naivete's Avatar
    636 Posts
    Global Posts
    640 Global Posts
    I would send it back for replacement. I had bad experiences with sandisk cards in the past. After using many cards, I learned that the brand of your card matters. I am using the adata card now.
  3. #3  
    Quote Originally Posted by NeoTreo

    Did I get ripped and have a 1GB card with a 2GB label?
    It would appear to be a 1Gb card.
  4. #4  
    Last time, I bought a 512MB RAM stick for my laptop and it showed only 256MB after installed. I had to exchange it..... Just a thought.
  5. #5  
    I just got my 2GB (Patriot - from newegg) SD card 2 days ago and had almost the exact same problem. It's working now, but due to dumb luck and I'm not sure how confident I am that it will be stable down the road.

    Here, in excrutiating detail, is how my situation went:

    When i first got the card I popped it in my (verizon, firmware 1.03) Treo650. It asked if I wanted to format it, I said yes but got an generic "cannot format" error. I popped it in my card reader and formatted under XP (fat, not fat32). When it was done formatting it said it was only 955MB. Tried same card reader (the only one I have) on another XP machine but it too formatted as 955MB.

    I decided to try it again in my treo and see if it would reformat now, or at least even see it. This time when I popped the card in I got stuck in an endless soft reset until I removed the card.

    I then popped it in my digital camera. At first the camera also saw 955MB as well, but when I formatted with the camera it saw the correct 1.8GB.

    Back in the treo. No more soft-reset-loop but it asked to format when i inserted and again got the "unable to format" error. I had decided that it wasn't compatible and planned to send it back. I even meant to remove it and put it back in the box, but forgot and left it in the phone. That's a good thing, because my treo locked up today and after a soft boot it now sees the card

    Try formatting in a digital camera, pop back in the treo, and do a soft reset.
  6. #6  
    Well... I spoke too soon. If I remove the functioning card from the treo and reinsert it once or twice it will stop recognizing it and ask me to reformat. Looks like this Patriot chip won't work in my phone. I'll try exchanging for the adata one.

Posting Permissions