Results 1 to 5 of 5
  1. ceb
    ceb is offline
    ceb's Avatar
    253 Posts
    Global Posts
    538 Global Posts
    I'm posting this from my treo 650 (Sprint) and can't seem to search.

    I'm in a remote location with a strong signal and need to hook up (via BT) to a Dell X1 (I have admin rights). BT seems to connect and I set up the 650 as a modem (COM 40) on the Dell accepting all defaults. I set the phone number for #777 and the password to the last 4 of my SSN.

    The treo dials and tries to connect, but I ultimately get a "connection failed" on the Dell and the treo automatically redials.

    What am I doing wrong? I do have an eval copy of PDANet on my flash drive if that helps.

    HotSync is NOT installed on the computer but I do have the disk.

    Any help would be appreciated - your country thanks you......I need this for work - yes I'm working during the much for govt employees having banker's hours.....

  2. #2  
    I just received an X1 yesterday and am having exactly the same problem. Have you had any luck getting this to work?


  3. #3  
    All I can say is good luck. I've had an X1 for months. I've only once been able to get my Treo to work as a modem. BT-DUN does not appear to work very well wiht the X1. I think it's a problem either with the BT stack or a problem with the string command to the modem to start dialing.
    If at first you don't succeed...skydiving is not for you.
  4. #4  
    Here's my experience, does it match yours? (also posted in another thread):

    I'm able to get the X1 and Sprint Treo 650 to pair (with some difficulty), and I've set the dialup number to #777, but when I actually go to connect, the connection fails, as though there is some issue with issuing the dial command to the Treo. I've uninstalled and reinstalled the Toshiba stack, recreated the connections several times, toggled BT and DUN on/off on the Treo, clearly seems something isn't right on the X1 side. I've successfully had BT DUN working with this Treo 650 on several other devices, just not a Toshiba BT based Dell.

    When connecting, it seems like there is some kind of handshake going on with the Treo, it will light up, but in the "Dial-up Connection" status area on the laptop I see:

    Dialing attempt 1.
    Could not detect modem. It may be in use, turned off, or not installed properly.

    As far as I can tell, everything is installed correctly on the laptop, the devices are paired, in the Bluetooth settings "Details of Michael's Treo" it appears that the BT stack is happy with the configuration:

    Device Name: Michael's Treo
    Device Address: 00:07:E0:6C:2E:6A
    Device Class: Telephone (Smart phone)
    Service Class: Dial-up Networking
    Service Name: Dial-up Networking
    Provider Name: None

    Port Name: COM40
    Auto Connect: On
    Connection Name: Michael's Treo

    I've tried it both with and without providing a username and password, same results.

    Thank you for any suggestions!

  5. #5  
    Got the Dell X1 working with the Sprint Treo 650 Bluetooth DUN!

    First, I uninstalled the Toshiba BT stack using the control panel "Add/remove programs", renamed the /windows/inf/bth.bak to bth.inf and rebooted the system. It then found the Dell 350 Bluetooth adapter and loaded and installed the Microsoft Bluetooth driver stack.

    Using the Microsoft Bluetooth control panel, I then found and added the Treo 650 to the list of devices.

    Also, under the Treo device properties/services, the system found the DUN service, which I selected to enable. The system then added the Bluetooth COM port and the Bluetooth modem. I did not have to manually add a COM port for the Treo.

    Also checked the "Show the Bluetooth icon in the notification area" box in the Bluetooth Devices control panel options area just for fun.

    So far so good....

    Went to the Network Connections control panel, added a new dialup network connection, set to use the Bluetooth modem.

    Set the Dial number to #777

    Left the username and password blank.

    Told the system to Dial.

    Failed... some problem accessing the COM port.

    Tried again, same result, various problems connecting.

    Hmmmph... time for some desperate measures.

    Went into the Properties/Security tab and turned on "Show Terminal window" under "Interactive logon and scripting".

    Clicked OK, then tried to redial.

    This time got a terminal window with "OK" displayed. Cool! We now have a connected modem!

    Dismissed the terminal window and the system continued on to complete the DUN connection.

    Perhaps there is some delay required before making the connection to the phone that is fixed by bringing up the terminal window.

    Tried some web pages, including our corporate Exchange server, appears to work fine.

    Disconnected the network connection, turned off Bluetooth on the Treo. Turned it back on and tried the whole sequence again. Worked a second time using the Network connection I had previously setup.

    Looks like this may be the secret sauce for making the Dell X1 work with a Sprint Treo 650.

    Also, be sure to disable having the Treo DUN be the default internet connection unless that is what you intend...

    Oh happy day!


Posting Permissions