Results 1 to 7 of 7
  1.    #1  
    I have a 1GB SD card which I use with my 650 - have a bunch of various things on it.

    For the first time yesterday I pulled it out of the treo and put it in my PC's SD reader (HP - built in). Windows acknowledged it and gave it a drive letter as you would expect, but when I tried to 'open' it to view the contents, Windows says it is not formatted...?

    Now, I know it is as I have MP3s, pix, programs, etc., all of which I can see in the treo.

    Why can't I see it in Windows?

    What to do?

  2. #2  
    I had a similar problem before but in my case, sd cannot be read by windows and treo. It became inaccessible after I popped out my sd from the bulit in reader of my notebook while it was still being read. The thought of losing data especially since I didn't have a backup was hust horrifying. Thanks to Google, I found and downloaded a trial version of this recovery program. There are a lot available that claims they are the best, but this did win an award. (I will post a link when if you need to know) After seeing that my files were recoverable, I bought it. It worked and I was able to recover all of my files. : ) I now backup my sd using Microsoft's Synctoy using the echo function. Thanks to Jeff Kirvin for the tip on this.

    To answer your question, just try removing the sd again and inserting it back. I have experienced the same thing before and it just maybe due to windows not being able to read the card immediately after detection. Also check if you have the latest driver for your card reader. Does your windows pc have enough ram?
    Last edited by MFB; 11/19/2005 at 12:22 PM.
  3.    #3  
    I am using whatever driver Win XP SP2 has internal - not sure how you would update it...

    PC has 1GB of RAM
  4. #4  
    Is your card reader reading other sd cards?
  5. #5  
    I have the exact same problem. I bought a SanDisk UltraII 1.0GB SD card. I did not format it. I just started using it in my Treo 650 with no problems. I pulled it out and put it in my HP laptops built in card reader and it shows a drive letter for it and a great looking picture of it but when I try to open it it asks me if I want to format it? I tried it on my desktop computer with the same result? Anybody know what the problem is?
  6.    #6  
    That's exactly the behavior I am seeing.

    Being that you said you see it on another reader, not thinking it is specific to our HPs...

    No, I do not have another SD - my cameras both use Compact Flash, so I have like 10 of those, but no reason for SD other than Palm device...
  7. swagner's Avatar
    258 Posts
    Global Posts
    283 Global Posts
    It is an issue with HP and the reader they use. It cannot read 1GB cards or larger without a new driver. I had the Same issue on my tablet PC.

Posting Permissions