Results 1 to 5 of 5
  1.    #1  
    A friend had a Palm III that she was about to throw away because she said it was "dead". So now I have it. I put in a fresh set of batteries and it was working perfectly for about a week. It now seems that the Palm III is sucking too much power from the batteries. It works but within two to three days the batteries are dead. I can turn the unit on and literally see the battery indicator decrease from full to about 60% in a matter of minutes. Has anybody seen this before? If so is there an inexpensive fix? Could this be related to Flash ROM? I want to sell it on eBay to get a least a few bucks.

  2. #2  
    Try a soft reset in case it's stuck in debug mode somehow (accidental use of a dot shortcut?).
    "Yeah, he can talk. It's gettin' him to shut up that's the trick!"
  3.    #3  
    Thanks Tom for your tip but it didn't work. I put in a fresh set of batteries--Energizer e2. After three days the Palm III has drained the batteries dead. I performed several hard resets when I first put the new batteries in and that didn't help.

    Anybody else have any suggestions?

  4. #4  
    I too had the problem with my visor.
    There are many threads on this subject here in the discussion forum. Bottom line that I got from them is that the unit is shot and needs replacing.
    You can read them yourself. Go to the opening page of the discussion forum and at the top do a search using "Battery Drain" as the key word.
    Also you can do what I did. I took mine back to the store(staples) where I made the original purchase over 10 months before. I had lost the receipt and had none. But if you talk nicely and get a sales manager (that got up on the right side of his bed), they will replace it for you. They did mine!!!!
    Good Luck
    P.S. If you decide to ditch it Please don't pawn it off on some other unsuspecting person who doesn't know better.
  5.    #5  

    Thanks for your input. I got a tip to open up the Palm III and to reseat the display cable and the memory card. If that didn't work then probably the motherboard had gone bad. Well so far it's seem to have worked, I'm in the midst of testing it. I will know for sure by Monday whether this really worked.

    Also, you stated:

    P.S. If you decide to ditch it Please don't pawn it off on some other unsuspecting person who doesn't know better.

    I would never do that. I value my eBay feedback too much to jeopardize it.

    Thanks again,

Posting Permissions