Last night at home, I tried to play a music track on my 545, so I could listen to the stereo with the earphones. Media Player would not start. I tapped on the icon--anywhere I could find it--to no avail. Tried several soft resets, no luck. Uninstalled some software I had installed yesterday--no luck. Removed skin files I'd installed. Again, the Player wouldn't open. Since it runs from ROM, I didn't know what else to do but do a hard reset, which I did, and it fixed the problem. No sweat, I thought, I have a backup on my computer at work. This morning, I tried to restore from the backup and got the most unwelcome message that it wasn't a valid backup! I had done 2 backups since I've had the unit--an original full backup and then an incremental one. According to the HP tech support person I just spoke to, he stated his opinion that incremental backup didn't work. Fortunately, the backup program apparently put a copy of the original full backup in the Windows\Temp directory, so I wa able to copy it into the default backup directory and did a successful restore.
As far as the cause of the original problem--Media Player not starting--the rep didn't have a clue, and wouldn't even guess. He said I was right to assume that only a hard reset would restore the program to normal operation. HP isn't much help with these new units--this guy was shooting from the hip.
This kind of situation gives me a cold prickly feeling down the back of my neck. This is something I would have expected out of a previous version of CE, but not this one!
Hope this helps someone!