Results 1 to 12 of 12
  1.    #1  
    Ok, last week I upgraded to GRPS on my TREO 270. ALL WAS WONDERFUL.

    Yesterday, I drove from Savannah (TMobile area) to Charleston, SC (Cingular area). My phone didn't work AT ALL in Charleston...

    NOR did it work upon returning to Savannah. It just says NETWORK SEARCH and never finds anything.

    Occassionally i get the error SIM CARD DAMAGED OR MISSING if I try to use the net or something, but even the phone part doesn't work.

    Went to TMObile store, they were no help..... any suggestions?

  2. #2  
    Went to TMObile store, they were no help..... any suggestions?
    No suggestions, just a bit of panic. I travel 65% of the time, and I haven't traveled since I upgraded. I spend a lot of time in CA, which is Cingular. I'm a bit nervous that my phone won't work next time I roam. This is scary, as I use my Treo for business purposes, and I use the phone part A LOT!

    It's interesting that your phone wouldn't work even upon return home. Did the T-Mobile folks give you a new SIM?
  3.    #3  

    No, I went to TMobile store and they took the SIM out of my handspring and put it into a regular mobile phone and it worked fine, indicated the problem isn't with the sim -- just with the handspring in recognizing it.

    Handspring TECH support told me to download a redo reset file from their website, however I cannot find it on their site.

    There tech people also don't speak english very well, so its VERY FRUSTRATING when they are giving you all this tech stuff you have to right down and you can't understand them.......

    Still hoping for suggestions

  4. #4  
    Shannon, I wish I could help with a suggestion. Hopefully I won't be searching these posts next time I travel outside of T-Mobile's area!

    Wait, I do have a suggestion: Way back when I was using a Handspring VisorPhone with my Prism, I had SIM problems. I went to a (back then) Voicestream store, and they tested my SIM in another phone, and lo and behold, it worked! Put it back in my VisorPhone, and it didn't. I asked for a new SIM anyway, and that did the trick. It may not work for you, but it's worth a try. (It would certainly be an easy thing to try, anyway, versus the file download that Handspring suggests.)

    As for tech support at Handspring, I've always found them to be very helpful and usually knowledgeable (except that they always ask you to try what you've already done - soft reset, hard reset). But you're right, THEY ARE SO HARD TO UNDERSTAND!

    If I have any problems next time I roam, you can bet I'll be posting here again. I'll be watching this thread to see if you get your problem resolved...

    Good Luck,
  5.    #5  
    Well, Handspring walked me through a few steps including a hard reset and after that failed informed me they were replacing the TREO 270 FREE OF CHARGE.

    They said this is an emerging issue and they can't pin down why its occuring because its occuring in a wide variety of circumstances including people traveling overseas, using a different SIM CARD, and upon returning home, when they put the SIM card in for the American carrier, it doesn't work.

    They've also had it happen they told me when someone just took a drive out of the service area, not even roaming into another network, but it woulnd't reconnect....

    So, the good news is they are being cool about fixing the problem.....

  6. #6  
    same thing happenned to me - roamed into VA from OH and, upon return, fried sim = free replacement
    R. Evan Stevens
  7. #7  
    This is very disturbing. I will be traveling to Baton Rouge from Houston in about a week. It looks like I won't be roaming (map on TMo website), but I'm nervous. I know HS is good about getting a replacement unit to you quickly, but if this happens to me, I'll be on my fourth replacement unit. Once was for the speaker (earpiece), the second for a bad screen, the third for a failed GPRS upgrade (see Sector Lock thread about this; HS said the Treo I had wasn't GPRS compatible -- funny, I thought they were supposed to be from the start....).

    I use my phone for business purposes A LOT, and I travel all over the country, spending a lot of time in California, which has me roaming on Cingular. Even though they replace them quickly, this will be a real pain in the **** if I have to deal with this while on the road.

    Question for savsb and restevns: How long have you had your Treo? Maybe the recently replaced one I have won't have the same problem.

  8. #8  
    I find this thread very disturbing too.

    I'm wondering if restevns and savsb have version 1.1.1 of the GPRS updater or not.

    It is frustrating to have waited so long for the official GPRS update, only to be faced with a variety of bugs and problems.
  9. #9  
    I didn't make myself very clear - sorry. Replacement was a SIM Card replacement, not a Treo Replacement. This prob occurred using SPRS Update 1.1, also, not 1.1.1

    I travel frequently - so will update if it happens again.
    R. Evan Stevens
  10. #10  
    I'm a Cingular customer in North Carolina. I ran the 1.1 updater, and recently the 1.1.1 updater. I've roamed into T-Mobile service areas in Virginia, Atlanta, and Florida with no issues so far. GPRS and phone service just work... so far.

    Lucky me, I guess.

  11. #11  
    I'm a Tmobile user in Dallas, Texas, but I performed the 1.1.1 GPRS update while I was in Northern California last week. Once updated, it worked fine roaming on Cingular's system all throughout Monterey, San Jose, San Francisco, the East Bay (etc.). In fact, I was pleasantly surprised at how good Cingular's GPRS coverage was in all these regions. Then when I got back home, GPRS et. al. continued to work here as well.
  12. #12  
    OK, I'm feeling a little better now about traveling, but sometimes I catch "Murphy's Law Syndrome", and just can't shake it... Like I said a few replies up, I'm already on my third 270, and if I had to replace my Treo again like savsb (see quote), I'd be pretty upset. I'll post here again if I have to get mine replaced again when I roam...

    Originally posted by savsb
    Well, Handspring walked me through a few steps including a hard reset and after that failed informed me they were replacing the TREO 270 FREE OF CHARGE.

Posting Permissions