I'm on my second 180. First one's radio died on it's 3rd of 4th day of life. Before that was my VisorPhone. With all 3 (VP, Treo1, Treo2), I've been able to dial-up, surf, get email, AIM, etc with A4F no prob. Up until about 3-4 weeks ago, it stopped connecting. I called VS to make sure they still had my data connection stuff turned on, it is. I wrote A4F support. 1st time it bounced, 2nd went thru - I have yet to hear from them. I joined BudgetDialup. Still no connect. I've tried several access numbers for both ISPs (found when I first joined A4F that some numbers would connect, some wouldn't - guess it was dial-up speed), but no go on the diff. numbers. I've tried enabling call waiting, disabling it, changing 'connect speeds', etc. to no avail. I've called the numbers using the phone part, and yes, the ISPs are answering, and I'm getting that groovy screech from all numbers called. The Treo just doesn't want to connect anymore...

Anyone else have this problem, or know what it might be, and how to fix it, if possible? Looks like we're still a little ways off from GPRS in my area, and it's too expensive looking anyway for now... I just want my dial-up-ability back. This is my 'Communicator', and I felt on top of the world and connected when all was working as it should - hell, I even left the Desktop from time to time... ;P