Results 1 to 5 of 5
  1.    #1  
    I'm trying to reinstall the Sprint 1.20 firmware onto a Sprint Branded Treo 600 that I loaded the Verizon 1.11 firmware onto. I installed the Verizon firmware using the method described by chrisjhahn in the following thread:

    I've tried restoring the revn and crnm values back to 1.10 (making the 1.20 updater think the Treo has an older firmware version) and SPR using Tokenwriter. The problem I'm encountering is when I try to run the Sprint 1.20 firmware updater it tells me that the ROM currently on the Treo is already newer than the one I'm trying to load. I've tried entering in different version numbers using Tokenwriter but with no success.

    I want to say the firmware checker app that PalmOne uses before the updater loads is actually basing the firmware date and version upon the build date of the firmware.

    Does anyone know of how to revert a Verizoned Sprint T600 back to the Sprint firmware?

    Thanks in advance.
  2.    #2  
    Anyone have an idea? 39 people have viewed this thread and not one response.
  3. #3  
    Got it.

    First, I did all of the above, plus a soft reset to get out of the error message, to no avail. Then I figured out the following. *Should* work. Write me if not.

    1) Download the Sprint updater from PalmOne
    2) Run the updater to the point where it wants to sync the phone
    3) Do the sync. "OK" to the reset. "OK" to the version error message. After the error, the updater on the phone will automatically delete itself.
    4) Back on the desktop, search for a file with a name like "Sprint_1_20_Updater.PRC".
    5) In the Palm Desktop, do View/Install/Add, and mark that file for downloading again. Do NOT mark the neighboring "SprintChecker*.PRC" files for downloading again.
    6) Do the sync. You should see an "SPR 1.20" app sitting on the Treo. Run it. It'll unpack some files. It'll give a version error message again (same text, but from a different source.) STOP.
    7) Do a soft reset to get out of the version error.
    8) There should be an app named "D.C." sitting there. Run it. Wait for 15 minutes while your firmware upgrade proceeds to a happy completion.
    9) Back on the desktop, DELETE that "Sprint_1_20_Updater.PRC" file. Otherwise, it'll download again and the firmware update will completely repeat itself (ask me how I know...)
    10) Do a sync to (hopefully) reload all your apps.

    At this point, everything was cool for me, except my phone banner string showed as "Verizon Wire". Do the procedure here to fix the banner.

    Hope this helps someone.
  4. #4  
    P.S. -- Had some trouble getting the phone activated onto the account. The procedure stumbled at the Sprint step of entering "##(6-digit code)". Long and short of it was that the "six digit code" apparently was the MSL (Master Subsidy Lock). Which, of course, on my phone had previously been cleared to zero. The tech (eventually) heard me and tried "##000000". Which worked, further magic numbers were entered, and then I was on the air.
  5. #5  
    You are a god! I spent at least four hours trying to work through this problem before stumbling across your post. Thanks so much!

Posting Permissions