I'm a new Sprint customer. I have the Professional Vision plan.

I am trying to get this resolved through their customer service, but they are highly dysfunctional and this will take a long time.

So I wonder if anyone here has dealt with this problem:

It mostly works:
I _can_ surf the web.
I _can_ send and receive email with 3rd party apps.
In my Business Connect, I _can_ sync with my Outlook desktop where I have the client installed, and can send and receive.

But I configured an additional IMAP server, and from there I _can_ receive, but _cannot_ send mail.

I tried leaving the SMTP server blank, as recommended, to use smtp.sprintpcs.com I presume.
I tried entering that server explicitly.
I tried using another SMTP server that allows me to relay, once authenticated. (But the BizConn configuration has a checkbox for authenticated SMTP, but no place to enter the logon/pw.)

The weird thing is, I can specify smtp.sprintpcs.com in a different
email program to send (authenticated).

Any ideas?