Results 1 to 8 of 8
Like Tree3Likes
  • 1 Post By Chester Holthausen
  • 1 Post By dimitrists
  • 1 Post By eoga
  1.    #1  
    Hello webOS friends,

    I'm struggling to turn on the subtitles when my media is being streamed through wi-fi share. (The media is in my computer and it is shared by wifi connection, going directly to the TV)

    1. The name at ".srt" extension matches identically the media name. (I'm not forgetting this point)

    2. The same media and subs, when connected by USB, works perfectly. The option to activate the subs is there, I turn it on and watch the video with no problem.

    Anyway, when I try to watch directly from my pc folder, it doesn't work. (The subs apparently doesn't exist. It's not even showed as an option)

    Anyone with the same problem?

    How can I fix this?

    Thanks guys
  2. #2  
    I don't know an answer, but I might suggest, if you're using Windows 7 or 8, I think it automatically provides a DLNA server that you can use, I think all you need to do is add the media to your Windows Media Player library. Otherwise, you could install the Plex media server (or the LG Smart Share server, which is either a re-branded or modified Plex) and connect to that, instead of trying to do it via.. i'm not sure what method you're trying to do it via. :-D
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    People asked me for a donate link for my non-catalog work, so here you are:
  3.    #3  

    I'm using the smart share feature (wifi media share)...
    I can watch the video, but I'm not able to chose/watch the subtitles...

    When the same media is in a pen drive ,attached directly to the tv, I can turn on the subtitles...

    Sorry if I was not clear enough

    I'll try the windows media player library tip
  4.    #4  
    What I have discovered so far:

    The first time I've configured DLNA over LG smart share (native TV LG software) I didn't really know what I was doing.

    Well, Windows has it's own DLNA media server, which is a derivative of "windows media player", called "windows media server" I guess... I don't know how, but I've shared/configured my media over the windows media server. (So, in my computer, windows media server was configured. The TV uses "SmartShare" natively, of course).

    I was never able to activate the subtitles, so I searched for alternatives...
    imagine showing the subs icon dimmend, with no options:

    1. LG provides it's owns DLNA software for PC called "SmartShare", same native name of the DLNA software used in the TV.
    "SmartShare" for PC is the most friendly interface of all, but doesn't stream the subs as well...

    2. There are a second alternative named "Media link" (name shown only in the site), which is actually the "plex media server". (Rebranded)

    I wasn't able to properly set the "plex media server", found it too difficult...does it stream the subs?
    on the left the "DNLA certified" is the "smartshare". in the middle, the "Media Link" is the "Plex"

    And so far, I have tried others DLNA servers
    some of the PC media servers installed, including "smartshare"

    3. "universal media server":
    didn't work

    4. "Nero media home 4 essentials":
    Supposed to be able of playing simultaneously the video and the subs... Information given by the own LG in a support guide... Didn't work

    5. "Serviio":
    Has all the options, including hardsubs (burned-in subs). Both didn't work.

    Best achievement so far:

    6. "PS3 media server":
    It shows the subs (burned-in method), but the sound was off and the imagine was periodically frozen, probably because of the hardware highly demands on "printing" the sentences in the frames...

    I'll keep trying. if anyone has the same problem, please, tell here... so I'll know I'm not the only one
  5. #5  
    I found the same issue regarding streaming subtitle.

    When it goes from USB the subtitles work perfect, but when i use a NAS hard disk from my router the subtitles do not work.

    I already used PLEX, but it does not fit my case, because i would like to use the USB port from my router, which also share the media with all devices, and would not like to have my PC running all the time to use plex.

    Really digging a solution for this that from my point of view is a weakness from Firmware capability.
    Gabriel Douran likes this.
  6. dimitrists's Avatar
    2 Posts
    Global Posts
    4 Global Posts
    Hello to everyone .

    I never had a Problem streaming subtitles over WiFi.

    My configuration is 42lb731v and I have a nas from dink.

    The only difference I see from other people here is that I use twonkymedia server on my naps.
    Sometimes though subtitles don't show up at all but I came down to a simple solution. I have to restart my twonkymedia server in order to rescan the video directories or rescan them separately.

    Anyway for me it works.

    There is another problem that I am facing though. Some subtitles don't render correctly. They show up as random Latin characters instead of Greek subs. Editing them with everything I tired and nothing.
    This happens on USB stick either.
    Gabriel Douran likes this.
  7. eoga's Avatar
    24 Posts
    Global Posts
    26 Global Posts
    What I noticed, at least on my tv, is that it takes long time to discover the subtitles but eventually it does. If i have move and forgot to include the subtitles and I just download it and add it in that moment it wont work i would have to wait and hour or so, dont know the exact time it takes, but after this the Tv will play the movie with the subtitles.

    Right now I am using Plex only because I like more to have everything in order and catalog including the movies and tv shows poster, but i will definitely would love to have a way that it wont use the computer. Myabe a future version of xbmc or a better version of the LG media share.
    Gabriel Douran likes this.
  8. #8  
    Thanks to dimitrists. His post solved the problem for me.
    Using twonkymedia server I streamed (most of ) external subtitles to lg 49ub850v - connected over LAN, software ver. 4.55.40 (I say 'most', because 1 mp4 movie with .srt worked ok, the other didn't streamed the .srt. file; using an usb hdd, second mp4 loaded correctly the .srt ). I used tonkymedia server v.7.1.2 (free edition) on an oracle vm virtual box (host : windows 10, guest: win xp sp3,on an old laptop with intel p6000 processor,intel hd graphics, 6gb ddr3 ram, 320 hdd 5400rpm, wireless). This version of twonky supports network drives and it also could stream the popcorn folder real time ( popcorn player on pause, the movie can be played on tv with external subtitle .srt file;the .srt file has the same name as the movie file).
    I choose to test the software in a virtual box, because , a few month ago, on a win 7 machine, I also install all media servers (plex,nero,servio) and nothing worked for external subtitles (so I decided, this time, not to overload the windows with useless software).

Similar Threads

  1. Smartshare Movie Player - MKV And M2TS
    By animalebestiale in forum LG webOS TV
    Replies: 0
    Last Post: 01/08/2015, 06:05 AM
  2. Replies: 15
    Last Post: 08/12/2012, 02:41 PM
  3. Flash player issue with subtitles
    By iclim4 in forum HP TouchPad
    Replies: 0
    Last Post: 08/26/2011, 12:34 PM

Tags for this Thread

Posting Permissions