Results 1 to 3 of 3
  1.    #1  
    As of yesterday (5/15/2020) I still received gmail on my Veer but as of 3 weeks ago I cannot send.
    As of today I cannot receive or send.

    The Veer Email app reports 'triangle!': "The server's security certificate is invalid."

    I assume the certificates in question, as downloaded to Veer are:
    \sslcerts\googleimap.pem: incoming, good until today
    \sslcerts\googlesmtp.pem: outgoing, failed a few weeks ago

    My Email app settings are:
    imap.gmail.com, SSL port 993
    smtp.gmail.com, SSL port 465
    (I have played with alternate TSL/SSL and port numbers, with no effect)

    Certgrabber app (v.0.5.8) reports "Download failed" and refers me to error messages in ssslout, which reports:
    "2415:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:s23_clnt.c:601:"

    The funny thing is that the Certgrabber app output on the screen reports "There was a problem downloading the certificate.." BUT this message follows cert downloading for palm and/or yahoo servers, apparently not for imap.gmail.com or smtp.gmail.com. Similarly, the log file BasicCertgrabber.log reports the problem after downloading the Palm certificate.

    Would it help for me to modify the Certgrabber.sh (shell script app) to remove the unwanted palm and yahoo certificate checking?
  2. #2  
    Interesting, Gmail is still working fine on my Pre 3 with those same settings, using SSL, however two days ago AOL mail quit working all together, with those same settings. Also interesting is that both still work fine with Thunderbird on my Linux box using the same exact settings. I'm guessing that some Oauth2 certs have expired, or some such thing, but that's just a guess at this point.
  3.    #3  
    Tried hard again, but still failure to connect: 'triangle!'" The server's security certificate is invalid".
    I ran CertGrabber, apparently successful for servers imap.gmail.com and smtp.gmail.com.

    The previous reported "Download failed" for CertGrabber is a red herring, it only reports failure for an icloud server certificate I don't care about.
    [Note that I edited the shell script .developer/certgrabber/grabcerts.sh, to remove cert download for unwanted Yahoo and iCloud, so I would get only gmail certificates, but this had no effect. Some other copy of grabcerts.sh is being run and I can't find it, I would appreciate a hint to the location of the actual script that is run. Also a user-friendly error would have been 'Download failed for iCloud cert']

    So I have fresh gmail certificates, dated today, but the imap.gmail.com cert is declared invalid when I try to connect, and when I try to send an email it simply goes into the Outbox and stays there.

    For Password I am using my Google Account to generate a 3rd party app password. I get this 16 char password but it doesn't get past the "certificate invalid" error. I alternately try my Google Account password, no luck.

    I deleted my Gmail account and started over.
    Settings:
    Type: imap

    In server: imap.gmail.com
    Username: my gmail email addr: ..@gmail.com
    Password: tried both Google password and 3rd party app password
    Encrypt: SSL
    Port: 993 (also tried 995)

    Out server: smtp.gmail.com
    Authentication: Off (also tried On; but this should have no effect on incoming mail anyway)
    Password: same as above
    Encrypt: SSL
    Port: 465

    Invariably, attempt to "Sign In" with above fails with "Unable to sign in, the server's certificate is invalid".
    Therefore I no longer even have a Gmail account to try to sign in with.

    Actually I don't care that much about the outgoing, if I can just get the incoming when I'm on the road.

    This topic is discussed in a parallel thread "Gmail login credentials rejected" ending in successful login as of Apr 2020, but those procedures fail now (it was only a question of getting a good 3rd party app password from Google).

    I am stumped.

Similar Threads

  1. Getting restarted on TouchPad
    By MarshmallowPhantomBunny in forum HP TouchPad
    Replies: 4
    Last Post: 09/05/2020, 06:14 PM
  2. Replies: 4
    Last Post: 05/22/2020, 09:36 AM
  3. Replies: 1
    Last Post: 05/21/2020, 04:22 AM
  4. HP TouchPad won't turn on, Brand New Never Opened
    By ethan61 in forum HP TouchPad
    Replies: 10
    Last Post: 05/09/2020, 09:46 AM
  5. Replies: 2
    Last Post: 05/02/2020, 02:41 PM

Posting Permissions