Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By owkenobi2
  1.    #1  
    I've been able to use Webos Quick Install exactly once, and I had assumed my problem was the cable, as the end of my Veer cable was slightly misaligned, and when it worked it was after some fiddling. ( Fortunately I've got Preware, but there's lots of apps to try on )

    So I ordered a lot of 2 used cables on ebay, and I still have the same issue with WebOS Quickinstall on all 3 cables.

    I'm on Mac OS Sierra, the novacom drivers install fine. But WebOS Quickinstall just won't accept a password. The WebOS Quickinstall acknowledges an HP Veer is connected. I've tried changing the password for Dev mode a few times, and the Veer accepts my old ones and sets a new one, so I do know my password. I've toggled Dev mode on and off, I've made sure it's on Just there anything else to try?

  2. #2  
    Okay, I've luckily never set a DevMode password, but it seems this forum has the answer as in this post:
    Hopefully you should be able to use these instructions in the Mac Terminal (where '<password>' gets substituted with your password:
    novacom -r <password> -c add
    • registers your device on this host. no future password entry is required.

    novacom -r <password> -c login
    • opens new session. Session is valid until device disconnect.

  3.    #3  
    Thanks for the response. Attempting to do anything with Novacom at the terminal on my mac just gives me "failed to connect to server". However, I didn't know there was command line access to start with with, so I will continue to research.
  4. #4  
    You mentioned toggling DevMode on and off - it will need to be ON for novacom to connect

    -- Sent from my Palm Pre using Forums
  5.    #5  
    Thanks, yes, DevMode is definitely on.
    With regards to novacom, this is probably a dumb question, but according to the help, it defaults to a server of 'localhost'. How do I point novacom on my Mac to my USB connected veer?
  6. #6  
    Again, I think the only time I set a DevMode password was many years ago and my solution was a visit to the doctor...
    However, the thread I linked to seemed to indicate that you can register the password with novacom using the commands quoted above.
    Assuming the above works, what I would try is
    1. Reboot the Mac
    2. Plug in Veer cable
    3. Choose Just Charge on Veer
    4. Run: "novacom -r <password> -c add" in Terminal
    5. Run: "novacom -r <password> -c login" in Terminal
    6. Start webOSQI and hopefully it will connect...

    I don't think you should need to manually point novacom to your Veer...
  7. #7  
    Quote Originally Posted by owkenobi2 View Post
    Fortunately I've got Preware, but there's lots of apps to try on
    You should really get novacom running, but if you have already installed Preware, you can install arbitrary ipk packages with it on-device. You just need to get the ipk OR the URL for the ipk onto your Veer.
    You can get the ipks on there by:
    • Mounting the Veer's USB partition on your computer and copying files onto /media/internal (if you can mount the Veer's USB partition on your computer)
    • Emailing them
    • WiFi File Sharing

    You can also just send a list of URLs from the FTP site to your phone and copy those into Preware's "Install Package" URL field. If you go this route, be aware that for you need to include the username and password (blank) in the URLs and I think you need to url-encode special characters like spaces. Here is an example:
    You find the Canuck Coding Guide to webosQI on the FTP site at:
    Code: Apps/ca.canuckcoding.wosqi.guide_1.0.0_all.ipk
    To use that directly in Preware we add the username:
    Code: Apps/ca.canuckcoding.wosqi.guide_1.0.0_all.ipk
    And then add the password (which is blank or nothing):
    Code: Apps/ca.canuckcoding.wosqi.guide_1.0.0_all.ipk
    ** That's right, I just added a colon after the username - normally the password would follow the colon, but there is none!
    Finally url-encode the space in "webOS Apps":
    That URL was tested and works in Preware on my Pre2

    Look out though with installing stuff from the FTP site because the Preware feed system does a nice job of hiding stuff that isn't compatible with your device, but with these types of installs you are completely on your own!
  8.    #8  
    Sorry I didnt' respond for some time, work got crazy. I really appreciate your info here, I had no idea I could just use preware's install package.

    That alone got me up and running, and I've now moved to my Veer as my full time phone.

    I also recently discovered I can use WebOS quickinstall on an old Mac running 10.6 and it works normally.

    More to come!
    Last edited by owkenobi2; 11/03/2017 at 11:04 AM.
    Grabber5.0 likes this.
  9.    #9  
    I should note, in case anyone else is having trouble, my webosquickinstall issue was on mac os x sierra.

Similar Threads

  1. Something's hosed, Pre 3 won't boot
    By uwer in forum HP Pre 3
    Replies: 29
    Last Post: 11/03/2017, 08:50 AM
  2. webOS Doctor for Windsornot?
    By mcbeaven in forum Upcoming & Rumored webOS Devices
    Replies: 6
    Last Post: 10/18/2017, 11:11 PM
  3. Why do you use a Palm Pre in 2017?
    By davidg4781 in forum Palm Pre and Pre Plus
    Replies: 4
    Last Post: 10/05/2017, 08:34 PM
  4. Looking for the WebOS Eclipse Plugin
    By ami mizuno in forum webOS Development
    Replies: 18
    Last Post: 10/03/2017, 12:01 AM

Posting Permissions