Hi all,
after two days on web research and forum digging and failing haplessly I'm finally writing here....
I bought this Hp Veer 4G from a Chinese vendor on Taobao here in Shanghai. It had preloaded apps and patches already so I did a full erase. to get a reset version on Veer which thought I'd like.
To my surprise still some of the notifications were in Chinese. There was no serial number on the back as well as in the phone's 'device info'
Firmware- BU1.9.15(264)
IMEI- 00440015202XXXXXX
Hardware Version- A
On website it was said it it ATT's and presumed it might be locked. But its working here with ChinaUnicom.

I can't make palm profile from phone. every time I do it it throws error. Using it it dev mode and bypassed activation. Can't use app catalogue. Cant use update.

Anyway... I'm sure this device must be doctored before... because preware, impostah, few patched etc etc were already there.... So I though to doctor it myself and tried att's 2.1.2 webos doctor... but its stucks at 8% everytime.
WOSQI 4.5 is also of no use. It detects my veer but the app catalog is empty every time I try. I tried previous versions of wosqi but still the same.

installed preware getting an IPK from net but that too isnt working. while loading it shows some error and nothing works.

I'se used preware, impostah etc etc on my pixi before it worked like a charm. I dont know whats the problem here.

Now help me out here please. I'm a big fan of webOS and would like to see my Veer running as I like.