Results 1 to 3 of 3
  1.    #1  
    Yesterday I tried to charge my HP Veer and it keeps getting stuck on the black screen with a large USB symbol. It will not turn on or charge, and I do not know what to do.

    I have tried:

    -Holding down the power button and toggling the mute key
    -This works to get rid of the screen momentarily, but it always comes back to the USB screen whether I try to charge it or it just pops back up by itself.

    -Symbol key, alt, r

    -WebOS Doctor

    -Trying to unstick the up volume key (Doesn't appear to be stuck)

    NOTHING IS WORKING. Please any advice you have I would LOVE to hear it.

  2. #2  
    Probably stuck/shorted Volume Up key. Connect with novaterm and type "fsboot".
  3. #3  
    I was able to use my thumb nail, starting from the side and working my way around slowly to remove the back cover. After that, remove the SS frame that holds the battery in and the battery will pop out. Leave it out for a few minutes then put it back in and power it up. Sounds scarey but the back came off easier than I thought it would. Just be careful not to pull on the little cable connections inside the phone.

Tags for this Thread

Posting Permissions