Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By bluenote
  1.    #1  
    Sent it in fedex with signature and SRO
    No record according to HP Chat
    No number for me to call
    Now I have to spend tomorrow trying to find someone who can call the **repair facility in El Paso, talk to the guy who signed for the device (they have an SRO) and let me know where the device is.

    Gave HP repair zero stars on their "survey". Not for losing the device so much as for their chat service not being able to help (nor their 877 phone number with their call center in India).

    Edit: oh yeah, its a veer with TTS, one of the special Veers, I'll probably never see it again
  2. #2  
    Man, that SUPER SUCKS! Let us know how it works out. Good luck!

    P.S. It's really easy to make any veer have tts esp now that we have a meta doctor for 2.2.4.
  3.    #3  
    Thanks for the sympathy.
    I sent that survey in and got a call this morning from webOS support in the good ole USA.
    They traced the device and found it (the support person had given me one address to send it to and the email had a different address so it ended up at the wrong repair facility).
    The webOS support person here is really on the ball and promised it back to me next week.
    I am relieved although I may not get my original device back.
    I bought it off HP on ebay and it had TTS already installed and a profile on the development server.

    We shall see.
    OldSkoolVWLover likes this.
  4. #4  
    The problem is that the Veer is so small it's easy to lose! :-)

    Good to hear they found it.

    BTW have I mentioned this week....I really love my Veer!
  5.    #5  
    Finally got the Veer back, 20 days after they received it and 25 days after I sent it ground.

    The good thing is that they fixed it, replaced the screen, but did not wipe it at all so I still have TTS and 2.2.4.
    The weird thing is that they put a piece of paper in the bag that said the device was not repairable.

    It came back the same way as I sent it , with a dark screen and just the notification light blinking. I'm wondering if that is why they thought they could not fix it.
    I too thought it was broken when I just had the dark screen and that is why I sent it in.

    When I got it back today though I had the good sense to plug it into the laptop and start up WOSQI which recognized the phone after it charged a bit and the screen finally lit up. So now I am wondering if I even tried that step before I sent it in. Or just charged it and did not fire up WOSQI. I think probably did not.

Posting Permissions