Results 1 to 8 of 8
  1.    #1  
    I know this is a common problem and I have read the other threads pertaining to it. However, none of the fixes work for me because 1) the veer has no headphone jack to stick anything (alcohol, graphite etc.) into, 2) I'm pretty sure it's not a hardware problem since I ran the diagnostic and everything worked as it should within that test and 3) I do not even own a non-bluetooth headset that will work with the veer. My problem started this morning after I had been using the phone with my Jabra bluetooth earpiece. I turned off bluetooth after I got to work (like I always do since it's a battery vampire) and then I noticed that the phone would only answer in speaker mode or it had a picture of a headset that I'd never seen before and which made it so that I couldn't hear anything. I'm not sure if my phone is even under warranty so I'd like to fix the issue myself if possible. I noticed there's a patch but I'm afraid to install it since it's intended for the Pre and I don't think it would work anyway since i don't have a headset to force it in and out of headset mode anyway. Any thoughts?
  2.    #2  
    Well this is awkward. Literally, as soon as I finished writing that post, I got a message on my phone saying that the 2.1.2 update was ready to install. So I figured, why not? I mean, the full erase didn't work so maybe a software upgrade will do the trick. Anyway, after the update, it's working just dandy again. Go figure.
  3. #3  
    I would gess it was the reboot after the update what "fixed" it, or did you have rebooted before?
  4.    #4  
    I actually rebooted it several times before the update happened. I even left it off for about 5- 10 minutes before I started it up again one time and it still wouldn't work. So then I tried a full erase and that didn't work either. It seems like the full erase installed an older version of the software which triggered the update and the update seems to be what did the trick. I admit i know almost nothing about this stuff though so I could be totally wrong
  5. #5  
    Thanks for follow up. Interesting storry. Glad you "fixed" it.
  6. #6  
    I'm having this issue with my Veer as well.

    The course of action would be to full erase the phone and see if an update is available? Or have we discovered a better fix for this?
    Palm m105 >> Zire 72SE >> AT&T Pre Plus >> Pre 2 (cracked)>>HP Veer/Pre 2>>Touchpad>>Pre 3...and I'm only 17 years old! (My own savings)
  7. #7  
    I would try to remove the device from the list of kown devices. Maybe even remove all devices in there.

    the full erase shojld be the last option before a dr.
  8.    #8  
    I admit, I tend to go the "shock and awe" route (i.e. start over from scratch) more quickly than some because its often faster and easier for me to do that than to troubleshoot until I figure out the exact problem. It wasn't my first course of action but, when the conventional solutions didn't work, a full erase seemed like the most efficient solution, time-wise. Also, I don't think I could have uninstalled the device even if I had thought of it. I don't own, nor have I ever used a non-bluetooth headset with my Veer. Since headset mode turned itself on in the total absence of an actual headset, I don't think there would have been a device to uninstall in the list.

    To answer Editor02, I don't know if the full erase and update would work for you or not. The "update" I was prompted to install was 2.1.2, which is probably the version of WebOS your phone is currently running. I didn't think to look at the software version between the erase and the update and I don't understand how the full erase works (e.g. if everything is erased, where does the OS software come from afterwards? a partition? the internet?) so I can't be sure, but I believe the full erase restored the phone to an earlier version of WebOS, triggering the 2.1.2 update, and fixing the problem. Therefore, I think it would depend on what version your phone came with as to whether this approach would work. I would also guess that, since the update fixed my phone, WebOS doctor might have worked too. Of course, I'm only guessing here so if someone who knows how this stuff works tells you differently, then go with their answer.

Posting Permissions