Results 1 to 2 of 2
  1. greg.hoch's Avatar
    42 Posts
    Global Posts
    45 Global Posts
    my veer seems to be broken. I went to bed yesterday evening and everything was fine. I woke up to the veer alarm clock but when I wanted to turn the alarm off the screen only showed black and flashing stripes. I was able to turn the screen on (flashing stripes) and off (black). Nothing else. The alarm rang again after some time (I guess I pressed snooze). I tried to restart guessing the right location and sequence of bottoms as well as Option + Sym + R. Not sure whether it worked. Maybe the phone restarted maybe it didn't.
    Here are two pictures (not sharp at all but you can still see the screen):

    Any suggestions? I bought the phone on ebay in the US and I am not even sure whether I got a receipt (I am in Europe right now).

  2. #2  
    if you cant restart it, let the battery run all the way down and then recharge it. it kind of sucks that you cant remove the battery for instances that you cant restart/reboot using the normal means.

Posting Permissions