Results 1 to 12 of 12
Like Tree6Likes
  • 2 Post By HP_TOUCHPAD_LuneOS
  • 1 Post By jonwise80
  • 1 Post By incidentist
  • 1 Post By jonwise80
  • 1 Post By incidentist
  1.    #1  
    Hi fellow webOS enthusiasts! I am resurrecting my TouchPad and am amazed and grateful for the wealth of info that has been amassed on this forum for the past 10 years. I've mostly got it up and running (Preware, etc), and the only major thing left to figure out is the Squid SSL bump. I would like to have it set up for general development, but my main challenge is that macOS Catalina does not run 32-bit executables anymore. Most of the tools out there are Java, which should work fine in Catalina, but they all require novacom/novacomd, which do not run anymore. I'd like to have a robust setup for being able to tinker.

    My current setup is: I run a Debian VirtualBox VM that can run novacom(d). I expose the TouchPad's USB to the VM, and then I can ssh into the VM from my Mac, and novacom into the device from the VM. It seems like novacomd is capable of running on a TCP port, which would mean that I can run novacom on my Mac and connect to novacomd on the VM. I have managed to get novacom to compile and run on my mac, but I can't compile novacomd. I've tried a few different ways of connecting to novacomd remotely but haven't managed to crack it yet. How do I run novacomd on a VM such that I connect novacom to it from another machine?

    On another note, what are people using their TouchPads for nowadays? I'm thinking of writing some small apps to control pihole and some other utilities I've got running on a Raspberry Pi in my basement.

    Thanks, everyone.
  2. #2  
    Hello!
    I do not know the answer to your question. It's a good question that we perhaps should consider solving at the next user meeting.

    It occurred to me that the easiest solution would be simply to use an old 32bit computer. If you don't have one, you might be able to borrow or pick up a second hand one cheaply. But maybe you don't have access and don't want to spend more money. Perhaps you do have a 32bit machine - how old is your Raspberry Pi? Could you use that?
    How to check whether a Raspberry Pi is 32 bit or 64 bit ?
  3.    #3  
    Thanks for the suggestion. I have an rpi3 but if I use that to run novacomd I'm still in the same position of wanting to connect novacom on my Mac to novacomd on the rpi, in a way that is transparent to novacom. If I just want to ssh into the TouchPad, my current VM-based setup works well enough, but ideally I'd like to run the various dev utilities on my Mac, and they assume that novacom is running on the same computer.
  4. #4  
    Hello baloneyshoes,
    The HP TOUCHPAD is the best WebOS Device ever created !
    I have learned a lot and the Touchpad has many uses and can be use for many things, more than before thanks to Android.
    Here is a list of all the things I have done to it, take a look:
    https://www.youtube.com/channel/UCKo...PU-Uq9UjcRR3hw

    Also all the details on XDA forum:
    https://forum.xda-developers.com/sea...chid=469214343

    I am a regular user, not a developer:
    I have put together Linux Live CD that has all the necessary files, as Novacom drivers to completely take control, thanks to jcsullin.
    This Linux version can be run on a virtual machine to have access to the novacom driver, it will even allows to modified the RAM disk:
    https://forum.xda-developers.com/hp-...droid-t3960435

    The DEBRICK Live CD can not be run from Virtual Machine, if is going to be use to re-flash the bootie:
    https://forum.xda-developers.com/hp-...ve-cd-t4189245

    Have fun learning ! Keep in mind the HP Touchpad is un-brick-able and can easily be fix go all the way!
    Youtube video:
    [/URL]
    Last edited by HP_TOUCHPAD_LuneOS; 11/16/2020 at 01:37 AM.
    jonwise80 and gazaud like this.
  5. #5  
    Quote Originally Posted by baloneyshoes View Post
    How do I run novacomd on a VM such that I connect novacom to it from another machine?
    Hi baloneyshoes! I've been following this because I'm interested in the solution -- but I haven't faced this particular problem (mostly because I quit upgrading my macOS after Mojave). However, I am curious why you need this. You said you can ssh into the VM from the host, so can't you issue novacom commands from macOS to the VM that way? Why do you need novacom to run on a socket at all, when you can just hop through ssh?

    Quote Originally Posted by baloneyshoes View Post
    On another note, what are people using their TouchPads for nowadays?
    My Touchpad gets daily use as a reading device, and as a client for my Raspberry Pi(s):

    • I use FeedSpider with InoReader to pull algorithm-free news. The nice big screen makes for a great experience.
    • I catch up on a few Reddits with IAmA Reddit
    • I read Kindle books with the first party Amazon Kindle app, that still works flawlessly
    • I control my Hue Lights with Hue Dash running on my RPi
    • I have a couple Podcasts I pull down and listen to when I'm exercising
    • Usually I have a ScummVM game on the go, but lately I've been working on Zelda on Snes9x Ex
    • The Touchpad sits on the charger on a bookshelf all day and shows the weather forecast or photos of the kids with Exhibition

    I've been starting to feature some of these apps in App Museum II, cause I don't think most people know how functional the TouchPad still is!

    Update: I've been using PushOver lately for events that happen on my RPi. It's awesome, and dead simple. I'm thinking I need to build a client for webOS!

    Quote Originally Posted by baloneyshoes View Post
    the only major thing left to figure out is the Squid SSL bump
    This is so much easier than anything else you've done so far, and so worth it -- it re-activates the web! If you've got a percent or two of horsepower available on your RPi, just run it yourself:
    Last edited by jonwise80; 11/13/2020 at 11:36 AM.
    gazaud likes this.
  6. #6  
    baloneyshoes,

    An idea did come to mind if maybe you are on an older Mac that did run at one time Mojave or earlier then the below should work.

    https://apple.stackexchange.com/ques...under-catalina
    Last edited by Eatsleepdrivesc; 11/21/2020 at 10:16 PM.
  7. #7  
    (I'm BaloneyShoes, the OP on this thread. I had a hard time recovering my ancient account here so I created a new one then figured out how to access the old account. Fun!)

    Thanks for the tips, everyone.

    Quote Originally Posted by jonwise80 View Post
    Why do you need novacom to run on a socket at all, when you can just hop through ssh?
    I guess I don't know how I'd get novacom running on MacOS to "hop through ssh" to the SSH running on the VM, and then to the TP.

    The endgame here is to be able to run the development tools on MacOS. They are java, so that shouldn't be a problem (right?) but they depend on novacom/novacomd, so I think if I can get novacom transparently talking to the TP through the VM (which is running novacomd), the java tools should work. It's also possible that I really don't understand how novacom works.

    Quote Originally Posted by jonwise80 View Post
    I've been using PushOver lately for events that happen on my RPi.
    Ha, I have a PushOver account too, but I haven't used it in forever. It looks like they have an API to create clients for it now, that's pretty cool.

    Re Squid: I gave your repo a shot, jonwise80, but my rpi is on buster and it wasn't working (I forget exactly what the issue was). I'm trying to use your configs as a template to set it up with a squid4 install. Though my *current* problem is that DNS on the TP is busted for some reason, so I can't test squid stuff until I figure that out.

    Quote Originally Posted by Eatsleepdrivesc View Post
    An idea did come to mind if maybe you are on an older Mac that did run at one time Mojave or earlier then the below should work.
    This is a great idea, but the overhead of rebooting into a different version of MacOS is more than the overhead of fiddling with a VM.
    jonwise80 likes this.
  8. #8  
    I see what you're after.
    I think your best bet would be to set up a shared folder between the Host and the VM -- then you could use modern tools on your Catalina host to write the code (I have some additions for VisualStudio Code you might want to check out), but use the VM to do the actual connect and deploy to the device.
    (You could probably modify my VS Code additions to do ssh commands to the guest, and have it work fairly transparently.)

    Its an interesting challenge, but as long as the guest is talking reliably to the device, its doable! Here's a generic example from StackOverflow:

    Code:
    ssh root@MachineB 'bash -s' < local_script.sh
    So on your host, you'd have your build script, and on the guest (MachineB) you'd have your connection to the webOS device. Run it from the host like:
    Code:
    ssh root@MachineB 'bash -s' < your_build_script.sh
    Obviously, you'd need to copy SSH keys from the host to the guest first, to avoid a password challenge. Examples of a build script are in my VS Code GitHub -- the only trick would be making sure the directories are aligned.

    As for the Squid install -- the main thing from that repo is the config and the startup script. You can actually do a normal sudo apt get install -- the paths are all different when you install that way, but otherwise the bits are the same, so you could merge my pre-Buster startup and config with a Buster version of squid, and do all the same stuff. Failing that, I have a hosted version of the Proxy service you're welcome to use: http://www.webosarchive.com/docs/pro.../#easy-install
    Last edited by jonwise80; 11/21/2020 at 11:04 PM.
    incidentist likes this.
  9. #9  
    Nice work on the VSCode extension. I think you're right, a shared disk and ssh commands are my best bet. I'd have to install the SDK on the VM and probably also my Mac, but that's fine. Thanks!

    Quote Originally Posted by jonwise80 View Post
    you could merge my pre-Buster startup and config with a Buster version of squid, and do all the same stuff.
    It turns out that the apt versions of squid are not built with
    Code:
    --enable-ssl-crtd
    . Furthermore, squid4 changes a lot of stuff and in my limited research I wasn't able to figure out how to translate the conf to something it would understand. In the name of choosing my battles, I signed up for your hosted proxy service.

    I thought I had figured out my DNS issues, but now it seems that networking just...stops working after an hour or two. Restarting wifi, and restarting the TP, doesn't work, but setting the network to "static ip" works for a bit, and then setting it to DHCP works for a bit. I can ping the raspberry pi from the TP, but nothing else. Very strange. I'll keep poking at it. Hopefully I didn't hose it while I was trying to configure something else.
  10. #10  
    Ah yes, squid4 is a different beast altogether. If it helps, my squid3 install works great on Ubuntu 20.
    I've approved your Proxy service account.

    I haven't had any DNS issues -- I run PiHole locally, with a backup in Azure, and my router dishes out the IP addresses of those DNS servers. But I have used Google's DNS as well. You could doctor the TP to get a fresh start -- although I'm not sure how well that would work with a VM. Here are simplified instructions for re-activating after a reset -- I'm working on a video too.
    Activating a webOS Device - webOS Documentation

    If you go Mojo, maybe my early thrashing will help.

    Can't wait to see what you build! Any idea if you'll start with Mojo or Enyo? If you're only going to target TouchPad, Enyo is a little more modern (and works on Pre3 too). If you want to build for the older devices, Mojo is the way to go -- and the documentation is so much more richer. There's even a book. I have very useful official developer docs restored here:
    webOS Dev Center - SDK-PDK Download
  11. #11  
    My instinct would be to go with Enyo because it's the new hotness (give or take 8 years), but I'd hate to restrict the potential userbase to just TouchPad users. I was actually a Mojo pro back in the day -- I did the webOS versions of the games Word Ace, Card Ace, Card Ace: BlackJack and Card Ace Casino. Although the thing about making games is we only used about 10% of Mojo because our UI was so customized. I remember wishing, at times, that I was making a "normal" app with buttons and menus and such. Now I get to try that out. Possible avenues to explore: Sonos, SyncThing, homebridge.

    I'm going to try using PiHole's DHCP server. My router is this Xfinity thing, and it wouldn't surprise me if there was some kind of subtle incompatibility. If that doesn't work, I'll doctor the dang TouchPad while singing a song about shaving yaks.
    jonwise80 likes this.
  12. #12  
    Whatever stack you use, let me save you some time: the built-in Ajax methods don't play well with JSON payloads in a PUT request -- they insist on mangling them into form-encoding, no matter what you do. I spent hours on it, before realising you can just use regular old XMLHttpRequests and bypass the framework entirely. That, combined with a SSL proxy, and you can pretty much do anything on the modern web -- its just a little more manual.

    Update: Tried out Word Ace last night, and got as far as I could exploring the others with the server's down. The chip stacking animation is perfect!
    Last edited by jonwise80; 11/24/2020 at 09:07 AM.
    Check out my webOS archival and development projects: http://www.jonandnic.com/webos

Similar Threads

  1. Need Help on Getting a new TV. interpolation tech issues
    By johnniearchangel in forum LG webOS TV
    Replies: 1
    Last Post: 09/17/2020, 09:33 PM
  2. WTB: White HP TouchPad
    By Gmbexpeart2020 in forum Marketplace
    Replies: 0
    Last Post: 08/15/2020, 06:30 AM
  3. WTB: HP TouchPad 64GB White
    By allen832008 in forum Marketplace
    Replies: 0
    Last Post: 08/03/2020, 12:51 PM
  4. Get mediaId value
    By pub615 in forum webOS Development
    Replies: 0
    Last Post: 06/03/2020, 11:18 AM
  5. WTB: White HP TouchPad
    By in forum Marketplace
    Replies: 0
    Last Post: 12/31/1969, 07:00 PM

Posting Permissions