Page 1 of 2 12 LastLast
Results 1 to 20 of 37
Like Tree29Likes
  1.    #1  
    I've got 3 Touchpads around the house, and have noticed that their clocks are drifting, despite the fact that the Network Time option is engaged. I'm gonna guess that HP hardwired them to check some HP NTP server that they've since decommissioned. Has anybody done a patch to fix Network Time in dear old WebOS? Or do I need to keep manually setting the clocks from here on out?
  2. #2  
    Look for an app called Clock Sync in PreWare, or the FTP site.

    Not sure why some TouchPads seem fine without it, and others need it.

    -- Sent from my Palm Veer using Forums
  3.    #3  
    Excellent. Thanks.
  4. #4  
    Quote Originally Posted by George Mari View Post
    Look for an app called Clock Sync in PreWare, or the FTP site.

    Not sure why some TouchPads seem fine without it, and others need it.

    -- Sent from my Palm Veer using Forums
    Clock Sync: While its functionality can be compared with a ntp update service, it's not using ntp as there is no official (read for unmodified/unrooted webos devices) way to start a simple ntp update or cron.
    Instead the application uses the date header from a request to a website that is known to have a synchronized time.
    I had a look, but I can't spot a reference to the website it checks...

    https://github.com/Lost-Projects/ClockSync
    Last edited by Preemptive; 07/23/2017 at 01:09 PM.
  5. #5  
    It appears to be here: https://github.com/Lost-Projects/Clo...backend.js#L18

    I would have to look at the version that I have installed on a Pre3 on my kitchen wall to verify if versions from other than github have a URL here.

    As for why the devices drift these days, it is because webOS used to point its ntpd to ntp.palm.com, but obviously that is no more. I haven't checked to see if defining an entry for ntp.palm.com in /etc/hosts would work. It probably would assuming there isn't any sort of certificate check.
    Did you know:

    webOS ran on a Treo 800 during initial development.
  6. #6  
    Good idea! Does anyone have a tip for a good NTP server?

    This looks useful: http://www.pool.ntp.org/en/
    Last edited by Preemptive; 07/25/2017 at 05:54 PM.
  7. #7  
    I played with the network time command on one of my phones (I can't remember the command or which phone) a while back, but it never occurred to me that it might be trying to talk to a palm server.. I do remember that it worked fine at the time. After doing a search, I believe it was ntpdate, which now fails unless I pass in a server name.
    Last edited by Grabber5.0; 07/26/2017 at 02:03 PM.
  8. #8  
    Herrie has a time service patch that needs testing. If it works, it can be added to Preware and the Service Pack meta-doctor. Post here if you are willing to join the test group.
  9. #9  
    Ooh ooh me.
    Follow me on Twitter
    For the latest webOS news check out pivotCE
    Preemptive likes this.
  10.    #10  
    yes, please.
    Preemptive likes this.
  11. #11  
    I am willing to test.
    Preemptive likes this.
  12. #12  
    Yes, willing test subject here.

    I've been happily using my Pre 3 as the time standard to set other clocks that don't auto-update, not realizing that it was wrong until I read this post.
  13. #13  
    Quote Originally Posted by dkirker View Post
    As for why the devices drift these days, it is because webOS used to point its ntpd to ntp.palm.com, but obviously that is no more. I haven't checked to see if defining an entry for ntp.palm.com in /etc/hosts would work. It probably would assuming there isn't any sort of certificate check.
    OK, I finally tried this. I'm afraid it doesn't appear to work (for me at least).

    Steps:
    1. I researched local timeservers, picked one and noted it's IP address. I did this because pool.ntp.org recommended this approach over using their service.
    2. I pinged the address from my computer and got a response (I previously pinged ntp.palm.com and got 100% failure).
    3. I edited my HOSTS file with the IP address , then 'ntp.palm.com', saved and checked the entry was definitely there.
    4. I set the time back 15mins in the date and time app.
    5. Network time was not on, so I turned it on.
    6. As written on the app card, I switched on aeroplane mode and switched it back off for a faster update. (no time change)
    7. I rebooted. (no time change)
    8. Successfully set the time with Clocksync.

    So, it's possible that it's specific to me and I urge others to test. It could be a certificate issue as suggested by dkirker or perhaps the webOS timeservice is in some way non-standard.
    bbito likes this.
  14. #14  
    I edited my HOSTS file with the IP address , then 'ntp.palm.com', saved and checked the entry was definitely there.
    Hey Preemptive,
    mazzinia mentioned this last year and back in 2011 someone analyzing the webOS 2.2.3 startup routine found that the time service (ntpdate) was looking to a different ntp server:
    Code:
    # does ntp time update from ntp0.palmws.com (ntpdate -bqu)
    https://forum.xda-developers.com/sho....php?t=1305170

    So that might be worth a try in your step #3
    Code:
    xxx.xxx.xxx.xxx    ntp0.palmws.com
    Preemptive likes this.
  15. #15  
    Quote Originally Posted by bbito View Post
    Code:
    xxx.xxx.xxx.xxx    ntp0.palmws.com
    This *seems* to work

    Here's what I did with a touchpad (webOS 3.0.5) that would just say something like 'will sync time when network / server is available' when set to Network Time:
    1) Edit /etc/hosts with internalz pro adding:
    Code:
    208.75.88.4     ntp0.palmws.com
    2) Restart - I figured that it would run ntpdate during startup, but the time was still wrong when it came back up.
    3) Go to Time & Date app and turn Network Time back Off
    4) Turn Network Time back On
    5) Within a few seconds Time was corrected and that 'will sync time when network / server is available' message disappeared

    I got the 208.75.88.4 IP by pinging 0.us.pool.ntp.org on Windows - I don't know if it is a great IP to use, but good enough for proof of concept....
  16. #16  
    OK.
    • I copied the HOSTS file from /etc to media/internal using Internalz Pro.
    • I took the opportunity to update the 'master' HOSTS file from Blocking Unwanted Connections with a Hosts File (actually I could have just started with this and skipped the step above)
    • Set the time 15mins ahead on the Pre3.
    • USB mode & opened the file on my PC (because Internalz Pro tends to hang on this file for some reason).
    • Added in the Palm entries and added your new line.
    • Saved and exited USB mode.
    • Copied back to /etc with Internalz Pro again.
    • I was switching network time on and off, then aeroplane mode - nothing. I was about to restart, then it worked!

    This is great work bbito! I was obviously using the wrong initial target. I guess the substitute server you chose is US based and others may chose a geographically closer option, so I'll look into it further and maybe write some instructions on 'pinging', but it works for me!

    If anyone wants to test, please post here with your results so we can be sure it's working for all.

    It'll be great to present this at the next User Group meeting. Always good to see progress!
  17. #17  
    Also worked on TP using a local timeserver's IP address.
  18.    #18  
    this fix works!
    Grabber5.0 likes this.
  19. #19  
    Quote Originally Posted by Chris Holst View Post
    this fix works!
    It works, but it is less than ideal unless you are running your own NTP service on your network, e.g.:
    https://askubuntu.com/questions/1455...cal-ntp-server

    ntpdate should really be pointing to a pool (or multiple pools) instead of a single IP but that is the limitation of this HOSTS file method.
    Another thing that might be worth trying is sticking a "ntpdate" configuration file at /etc/default/ntpdate
    The /etc/init.d/ntpdate file includes the following:
    Code:
    if test -f /etc/default/ntpdate ; then
    . /etc/default/ntpdate
    else
    NTPSERVERS="pool.ntp.org"
    fi
    which by my read indicates that if we put an NTPSERVERS declaration in that file we should get access to a list of pools, e.g.:
    Code:
    NTPSERVERS="0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org"
    I'll update if I get a chance to test this on a Touchpad where I haven't already modded the HOSTS file.

    EDIT: I should have mentioned that normal installs of webOS 2.2.4 and 3.0.5 do not have that config file at /etc/default/ntpdate
    Last edited by bbito; 03/08/2018 at 08:43 PM.
  20. #20  
    Quote Originally Posted by bbito View Post
    Another thing that might be worth trying is sticking a "ntpdate" configuration file at /etc/default/ntpdate
    Got a chance to test and this does not work
    ...which makes sense because if NTPSERVERS wasn't getting overwritten somewhere than ntpdate should be looking at pool.ntp.org instead of ntp0.palmws.com...
    I did a fair bit of poking around before resorting to the HOSTS file trick and I couldn't find where ntp0.palmws.com is being set as the target...
    Time to setup an NTP service for my touchpads on one of my static IPs...
    Last edited by bbito; 03/08/2018 at 08:44 PM.
Page 1 of 2 12 LastLast

Similar Threads

  1. Not been here for a few years
    By demagbk10 in forum LuneOS
    Replies: 1
    Last Post: 07/18/2017, 02:30 PM
  2. uf6430 that will not read ntfs for 4k movies
    By bigdaddy131 in forum LG webOS TV
    Replies: 0
    Last Post: 05/04/2017, 10:11 PM
  3. Not to be a jerk.... i swear
    By 22350 in forum LuneOS
    Replies: 5
    Last Post: 05/03/2017, 10:51 AM
  4. touch screen not working
    By savin babu in forum HP TouchPad
    Replies: 2
    Last Post: 04/17/2017, 09:06 PM

Posting Permissions