Results 1 to 6 of 6
Like Tree2Likes
  • 2 Post By joeytino
  1. deafcheer's Avatar
    3 Posts
    Global Posts
    5 Global Posts
    I found my HP Touchpad in the storage that I haven't used for 5 years. It's completely brand new.

    I hope this forum is still active... sorta of.

    When I charge it, it's green blinking on home button. Is that normal? The screen hasn't come on with the battery icon logo displayed.

    Question is... how long does it take to make fully recharge the battery?
  2. #2  
    I just had this happen to mine when I left it off the charger and it went to sleep. plug it into a working charger and press the power button and center button and hold for as long as it takes. eventually it will reboot.
  3. #3  
    After 5 years, the battery might be too discharged to charge up properly. BUT you have a flashing light! This is a good sign - it's not completely dead.

    The general advice is to plug it into a standard 1A / 5V phone charger or a computer's powered USB port. This lower level current will hopefully tickle charge to a point where the charging circuit wakes up (can take a looong time).

    There are a few TP revival experts on here, so there will probably be some better advice if you post specifics about your progress.

    There are various fixes to get webOS up and running. You can also run Android (Nougat is the latest version). I think also Ubuntu and maybe Arch Linux. LuneOS is the new, open-source version of webOS. The latest stable version was released yesterday BUT this is still alpha software.
  4. #4  
    Green? I didn't think that IS normal. I thought it was only white.

    Regardless, A) the forum is reasonably active and B) many, many seemingly dead TPads have come back from a coma state, if you are patient and experimental enough you may get the charging circuit to come back to full function again. Then you can set it up as dual boot and actually use the hardware you found because it's still somewhat competent if you put an Android version on as well.

    Welcome to the forum!
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  5. #5  
    One thing to keep in mind is to be patient. It can and may take days for the battery to charge up enough for the TP to wake up. If and when it does, plug it into the the standard TP barrel charger and let it sit until it reaches 100% before you play with it. If it is truly freshly out of the box, you will need to bypass activation as the HP servers are no longer out there.

    Follow this thread for the process

    If you want to totally bypass webOS ( but why would you want to? Just kidding!), there is of course Android or if you are adventurous, LuneOS which is android based OpenWebOS that has been in development for some time and has made great progress.

    If you go webOS, there are a LOT of free archived apps available that you can install that still work well or at least reasonably well, (notably the USA Today app still works!) plus plenty of games that work fine. Plus you will want to install preware and a few other things, but one thing at a time.

    If after a week you still do not have any luck, it is possible the battery is too far gone to be revived. I found one where it was pretty swollen. There are replacements out there, but you will need to open up the TP and that is a bit of a challenge if you have never done it before.

    If it comes up, you will have a durable tablet that even after 6 years is still quite viable.

    Good luck.
    Last edited by joeytino; 09/19/2016 at 05:40 PM.
    TJs11thPre and Gerson like this.
  6. #6  
    I will try to be as descriptive as possible, I hope someone who is smarter than me can help. I had a fully functioning touchpad running Android, touchstone and charger (I know everything works). I went ahead and tried to install Nougat. In doing so, I decided to wipe the Web OS partition using tptoolbox (I assumed it was not needed as it is old and unsupported). Everything seemed to go great, I installed Evervolv's Android Nougat build as I was wrapping up at work and the touchpad was booting for the first time which I know can take a long time. I threw it in my bag as it was booting up showing the Evervolv logo and went home. I forgot about it until later that night and I went to my bag to find the touchpad was completely dead. I assume the bootup hung and completely drained the battery. I have tried all button combinations, left it on the touchstone for days, low amp chargers for days, external usb batteries for days and I tried the tpdebrick app which gave me an error (probably because Web OS is not installed on the touchpad I am guessing). Am I screwed? I am sad since I used this touchpad a lot. I have looked into Li-Po chargers, but they're $50 (more that the TP is worth at this point) Any help I can get would be appreciated.

Similar Threads

  1. Battery bad or dead Pro 850
    By ihatedeskjets in forum Palm Windows Mobile Devices & Apps
    Replies: 3
    Last Post: 04/30/2011, 11:46 PM
  2. Battery dead in three hrs
    By prmdc1 in forum Palm Pre and Pre Plus
    Replies: 23
    Last Post: 02/06/2010, 10:41 PM
  3. Dead Battery (Completely Dead)
    By theChrisLake in forum Palm Pre and Pre Plus
    Replies: 8
    Last Post: 09/11/2009, 09:37 AM
  4. Pre is So dead! - Possible Dead Battery
    By peterdhx in forum Palm Pre and Pre Plus
    Replies: 16
    Last Post: 09/08/2009, 02:23 PM
  5. What happens when the battery goes dead?
    By CarlGalgano in forum Palm OS Devices & Apps
    Replies: 0
    Last Post: 10/23/2003, 01:45 PM

Tags for this Thread

Posting Permissions