Results 1 to 7 of 7
Like Tree6Likes
  • 1 Post By Jason Robitaille
  • 4 Post By dkirker
  • 1 Post By Grabber5.0
  1.    #1  

    I made a wipe of my touchpad a few months ago, and i wanted to try LunaCE or LuneOS (legacy webos is great, but i wanted to play a bit with my touchpad).

    But, i run my PC with Ubuntu 16.04 / 64bits, and i tried a lot of solutions seen on internet to install these ****** novacom drivers.

    -> downloaded webosquickinstall 4.6, but the novacom driver installer doesnt work.
    -> downloaded .deb drivers ( Index of /pub4/sourceforge/b/bi/bioinfoserv/Packages/Version5.0-YuleFlying/WebOS/2.1 )
    But it doesnt change anything: no touchpad (or pre3, i own one) recognized.
    -> tried with webosdoctor (i thought it could install novacom with it) but doesnt work.
    -> novacom universal installer 1.4.1 doesnt work.

    So, in march 2016, it seems a bit harder to use WebOS on Ubuntu...

    If anybody has a tip (i begin to think installing a windows boot for webos....), i'd be really glad.

  2. #2  
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
    Preemptive likes this.
  3.    #3  
    Thx for these, but i already tried this .deb package.

    For a reason i dont understand, once the package novacom is installed, i still cannot connect anything under openwebos.

    I'll try under a windows boot...

    Thanks anyway.
  4. BjAdel's Avatar
    39 Posts
    Global Posts
    43 Global Posts
    Hi Zolann,

    I think I have a solution:


    sudo /opt/Palm/novacom/novacomd
    The reason on my system Ubuntu 16.04 was, that I havn't installed "upstart". Systemd is here installed.

    Cheers Björn
  5. #5  
    Quote Originally Posted by BjAdel View Post
    Hi Zolann,

    I think I have a solution:


    sudo /opt/Palm/novacom/novacomd
    The reason on my system Ubuntu 16.04 was, that I havn't installed "upstart". Systemd is here installed.

    Cheers Björn
    This is exactly what I have to do on Debian 8 "Jessie" too.
    IIIxe | z22 | Pre 3 | Bold 9900 | Q10 | Passport SE
  6. #6  
    Paste the following into the file: /etc/systemd/system/palm-novacomd.service

    Description=Palm NovaCom, Palm's debug/control protocol server.
    Then, from the command line execute:

    sudo chmod 733 palm-novacomd.service
    Now you can start the service with:

     sudo service palm-novacomd start
    Finally, call this command to auto-start the service:

     sudo systemctl enable palm-novacomd.service
    Last edited by dkirker; 11/22/2016 at 01:32 PM. Reason: Add auto start
    Did you know:

    webOS ran on a Treo 800 during initial development.
    Grabber5.0, uwer, bbito and 1 others like this.
  7. #7  
    Thanks for these instructions. I'll be doing these steps later today. I created a 16.04 virtual machine for something else and also installed the novacom package in case I want to use it for creating meta-doctors. I have a dual boot env for that, but it would be nice to not always have to reboot to use it.

    Edit: worked like a champ! I did have to try a couple of times to give the USB device to the VM because it failed the first time for some reason, but whatever.
    Last edited by Grabber5.0; 01/17/2017 at 10:44 PM.
    Shuswap likes this.

Similar Threads

  1. Help me for Novacom drivers win32
    By Pordenone Vive in forum Palm Pre 2
    Replies: 6
    Last Post: 12/02/2014, 12:22 PM
  2. Cant get Novacom drivers to download
    By Brent Tobiczyk in forum HP TouchPad
    Replies: 4
    Last Post: 11/21/2014, 11:41 PM
  3. arm novacom drivers
    By creepingmee in forum webOS Development
    Replies: 0
    Last Post: 06/21/2012, 08:28 PM
  4. Novacom drivers, where are they?
    By iharley in forum HP TouchPad
    Replies: 0
    Last Post: 10/06/2011, 12:56 PM
  5. Replies: 2
    Last Post: 01/24/2011, 04:33 PM

Posting Permissions