Results 1 to 15 of 15
Like Tree1Likes
  • 1 Post By Chris Holst
  1.    #1  
    I changed my Google password recently, and while trying to update it on my Touchpad, all I'm seeing now is a "Bad Request" error. Gmail had been working just fine for years, and a password change 14 months ago worked just fine. Is this more of their certificate shenanigans, or some other issue that has probably already been patched?
  2. #2  
    The primary cause is they shut down the APIs webOS was using. There is a patch that will restore it, but you must read and follow the instructions carefully and make sure you don't have any conflicting patches installed. See this thread: I had written a patch when they initially changed the old APIs to require SSL, but they have since shut those old versions down completely, so frantid's patch is the only one that works now -- and it restores full Google account functionality.

    There is also a certificate issue, where Google is updating all of their certs to SHA-256, which webOS doesn't quite natively support (it works, but not properly). There is an patch to update the OpenSSL libraries on webOS to accept these new certificates. It is in the alpha Preware feeds if you have those enabled, or you can find it here:
  3.    #3  
    Thanks for the pointer. That calendar patch thread looks like it is dealing with calendar behavior... but you say it affects all Google behavior? I'll follow the directions and see if it starts working again.
  4.    #4  
    Looks like it worked! Thanks for the help.
  5. #5  
    You're very welcome. Originally the patch was only for calendar sync, but the OAuth piece is now required for all google account authorization.
  6.    #6  
    So... how does the OAuth patch play with 2-factor? If I turn that on, am I in for a new set of headaches?
  7. #7  
    I don't think it's a problem, but I don't use two-factor. I know it has been discussed, I just can't remember.
  8. #8  
    Applications can't do two factor. So in your google account (somewhere in account settings-authentication in two steps-app specific passwords)you have to define you want to use an application and you get a 20? character long password you put in the place of your normal password and then your application can use your 2F enabled google-account..

    i hope this is clear enough...
  9.    #9  
    Clear enough, and I know what you're talking about. I think I'll leave the two-factor until the next time somebody in Timbuktoo tries to log into my google account and google warns me about it. Should be another year, at least, given the rate things go.
  10.    #10  
    Seems Google has changed something again and broke gmail access. It's not a certificate problem now, according to the errors generated, and going through the Oauth and getting a new token and recreating the google account doesn't fix it. It now says "Check username and password". They haven't changed from last week, but they don't work now.

    Anybody else having this issue lately? My last successful email download from there was at about 1AM on 1/6/16.
  11. #11  
    Quote Originally Posted by Chris Holst View Post
    Anybody else having this issue lately? My last successful email download from there was at about 1AM on 1/6/16.
    I just doctored my 2.2.4 FrankenPre 2 night before last and use CDAV for calendar and contacts and generic IMAP for gmail. I can send and receive on that gmail account currently. I do not have 2 factor auth.
  12. #12  
    I changed Yahoo PW. Works on TP, not on Pre3... Haven't looked into it further yet.
  13.    #13  
    This hasn't fixed itself yet... I'm going to try switching to 2-factor and see if that system will let me log in and get mail.
  14.    #14  
    Switching back and forth from 2-factor sorted it out... not sure why it wasn't liking the password for that period of time, but turning 2-factor on and off again get it to work again.
    Preemptive likes this.
  15. #15  
    Thanks. I'll give it a go on yahoo - but different provider might mean a different problem.

    Also the Yahoo SMTP certificate expires today for those still updating it manually...

Similar Threads

  1. [Patch Request] [Browser] Add to Google Reader "Starred Items"
    By Ubuntite in forum webOS Apps & Games
    Replies: 0
    Last Post: 11/01/2011, 03:45 AM
  2. Replies: 3
    Last Post: 05/03/2011, 02:53 PM
  3. Replies: 11
    Last Post: 08/22/2010, 01:44 AM
  4. Google mail "Password incorrect" fixed 1.3.5?
    By japark in forum webOS Synergy and Synchronization
    Replies: 1
    Last Post: 01/02/2010, 04:50 PM
  5. Patch Request: Turn off "Swoosh"/"Card Swipe Up" Sound.
    By DretheAce in forum webOS Patches
    Replies: 1
    Last Post: 10/09/2009, 09:15 PM

Tags for this Thread

Posting Permissions