Page 23 of 47 FirstFirst ... 13181920212223242526272833 ... LastLast
Results 441 to 460 of 923
Like Tree236Likes
  1. #441  
    Glad to see the solutions were found before I had a chance to check in again. Nice work with persistence!

    Yes, having the most current version of Preware is critical. V. 1.9.14 at the moment.

    And no, it is not Google's fault, this is technically HPs fault. It's simply a lack of support on our side to keep up with new technology standards. We all know this is part of the webOS legacy though.

    But I am so glad we have the forum, and the opportunity to contribute and support EACH OTHER.
    Last edited by TJs11thPre; 08/25/2015 at 11:43 AM.
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  2. #442  
    those of you who were getting the "illegal..." message when trying to run the script, did you find the solution? I either get "illegal" message or script is not found even though I can open it with wterm vi editor...
  3. #443  
    Quote Originally Posted by Jeff Marshall7 View Post
    As a side note...I looked at a Google forum the other day and noticed that one of the guys posting on there claimed he had close personal contact with some of the guys running Google. He claimed they said that Google had no interest in WEBOS and they do not support it! I cannot verify if that's actually true, but that's what I read on the Google forum. It looks like Google only cares about their own show.
    Well, that's hardly surprising. Remember, HP clumsily announced the end of any webOS hardware development in 2011. Though software development continued for a year or so beyond that, this public demonstration of lack of confidence in their own product effectively killed it. It's actually something of a surprise that LG bought webOS (perhaps it was a bargain?), but maybe it's an endorsement of the quality of the software.

    As far as the mobile industry is concerned, webOS is dead and has been for a while. This is probably a realistic assessment, though we have hope from LG's watch experiments and LuneOS. A number of top webOS people went on to work on Android. I'd imagine that Google are entirely indifferent to webOS, but why should they support a competitor?

    Any modern systems will be coping invisibly with these frequent changes. The problems we have are due to a bug which would have been quickly and easily fixed if webOS was still supported by it's creators.
    TJs11thPre and uwer like this.
  4. #444  
    Of course Google only cares about their own product! They'll offer support for other major OSes, but only limited.

    Ultimately, I am interested in poking around for a solution. I imagine the reason for so many certificates is likely because of the number of servers in use. Anyway, done properly, the certs should auth if the CA certs are imported into the digital trust. Best way is to inject directly. There was a guy, I think his name was Paul, who showed up to some webOS meetups in Silicon Valley who knows a thing or two about security. If I can remember who he is, I might give him a ping.

    I am, sadly, not an expert when it comes to deep security stuff.
    Did you know:

    webOS ran on a Treo 800 during initial development.
  5. #445  
    Quote Originally Posted by joshua764 View Post
    Hello. I just finished making the necessary files and is working in my pre2 and touchpad. I made a copy if anyone serve . one need only download and decompress the -zip on your pc ,
    2 pass the file name sslcerts USB device ,
    3 intenalz done to look for and open and trust certificates .
    thanks for this great work. webos forever.
    Nice one! This worked for me. Thanks to all those who are keeping webs alive!
  6. #446  
    I guess I sounded a little to harsh with Google's lack of concern for WebOS. And yes, others posting here are correct when they say Google is right in their assessment as it stands. Just thought I'd mention what I saw, but I suspect that many here already knew or suspected that. The tech world is continuously changing. And obviously, that includes all the OS software. Now MS is releasing Windows 10...and on and on to Windows nth. HP dumped WebOS which in my opinion was a classic bungle...they never really gave it chance to prove how good it is. But I think they were concerned about going down a possible dead end road. MS Windows and Apple IOS are formidable contenders that dominate the market. Trying to jump in with a relatively unknown OS would be a risky move from a business enterprise point of view. Just my2 cents here.
  7. #447  
    Seems by loading preware I have given my TP a new lease of life!

    Now installed internalz pro and a few games.

    Never realised all this existed.

    When someone wrote - how do you manage without preware - I thought to myself, well I do. Never
    realising what preware actually is.

    Thanks for the support and recommendation.
    TJs11thPre likes this.
  8. #448  
    this is sad. Amazon can not send me a pre3 please if anyone knows who can send mexico report.

    -- Enviado desde mi HP Pre

    -- Sent from my Palm Pre using Forums
  9. #449  
    Quote Originally Posted by Grabber5.0 View Post
    After wasting time and making no progress on this all week, I finally got gmail working again on my devices, and I'm embarrassed I didn't try it sooner. I have been talking to Alan all day and at some point during the discussion I realized that my Yahoo account was only working on devices where I had installed those new certs. Oh, this isn't the Yahoo thread? Right.. so Alan needed those and I re-captured them using the tip from the 'Fixing Yahoo sync' PivotCE article, and decided to see what happened if I captured the gmail certs the same way. So I captured them, saved them to three pem files, and copied them to my Pre2, opened each one in Internalz and trusted it. Then I went back to the email app and refreshed my gmail account and all of my email came in! These have also been installed successfully on a Pre3, Veer, Touchpad Go, and Touchpad.

    I've attached a zip file containing the three pem files with the updated certificates. Unzip, copy to device over usb (or just unzip there using wterm) and then navigate to the folder you copied them to and trust the certs. Or, you can open the certificate manager from the device info app's app menu, and hit the + button, and select the .pem files one at a time to display and tap the trust button.
    Thank! But, works only POP, when i try IMAP incoming server settings error

    UPD: in POP empty mail list, it does'nt sync
    Last edited by Andrey Zolotukhin; 08/26/2015 at 07:33 AM.
  10. #450  
    Then you have a "server SETTINGS error" ;-)
  11. #451  
    Thanks to all involved. I finally got email working today using the script.

    Is there any way to get rid of google1 thru google5.pem from the add list in Cert Manager or are they necessary?
  12. #452  
    Quote Originally Posted by synchron View Post
    Thanks to all involved. I finally got email working today using the script.

    Is there any way to get rid of google1 thru google5.pem from the add list in Cert Manager or are they necessary?
    Locate the original google*.pem files using Internalz and delete them, or hook to PC in USB mode and find and delete them. If you haven't already, also remove them from the trusted list in Cert Manager.
    Preemptive likes this.
  13. #453  
    just now I got back this error , I deleted the old certified products with script " " rerun scrip and validated the new certificates . I restarted the pre and it seems that everything works . And ' the right procedure to follow? Thank you
  14. #454  
    I deleted those files but the app freezes when displaying the add screen as if it can't find them. I put them all back and ran the script again and it works again with all five files showing up as well as cacerts.pem, and the newly grabbed files. It seems that the old googleimap and googlesmtp certs need to be removed as they get duplicated.

    Thanks anyway, no harm, no foul.
    Attached Images Attached Images
  15. #455  
    Quote Originally Posted by gizmo21 View Post
    Yes the whole updated script /with putting it to urs/bin is just for those:

    1. wanting to keep every pem iteration downloaded, to perhaps compare them.
    2. who are wanting to update "on trip" using the on device preware app WTERM (with root rights) instead of always connecting via USB and use WOSQI at home. You can then just open wterm, enter name of the script or tab on "UPARROW" (to get the lastest entries ) and press enter, and the certs will be always on the defined directory like horzel wrote.
    Can you explain how to use wterm ? I have root access and are in " / var / home / root # " but where I put the script to run from wterm .... ( ignore )
  16. #456  
    Put the script to /media/internal! This is the root dir of your USB partition. You can run it from there.

    Edith says:
    If you want to run an script from the current working directory you have to put a "./" in front of the name. (e. g. ./
    Or just refer to step by step guide from TJs11thPre. Here:

    Last edited by toto-w; 08/28/2015 at 07:12 AM.
  17. #457  
    so at the end of the day, how many certs does google need listed in the cert mgr?

    is it just the imap and smtp that the script pulls down? or do we also need a "google internet authority g2" cert?

    i have only these two right now listed in the mgr. mail seems to be working! ha!
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  18. #458  
    Only the Google IMAP cert is truly needed right now. The download of the SMTP cert is a precaution assuming they'll start changing it too. There are no changes to the intermediate or root certificates yet.
    Jeff Marshall7 likes this.
  19. #459  
    Quote Originally Posted by Grabber5.0 View Post
    Only the Google IMAP cert is truly needed right now. The download of the SMTP cert is a precaution assuming they'll start changing it too. There are no changes to the intermediate or root certificates yet.
    Yes, but what will happen to our client device if the intermediate or root cert is attacked and therefor updated?
  20. #460  
    Quote Originally Posted by TJs11thPre View Post
    ok, i know how frustrating it is when you feel you don't have the "know-how" to do this DIY stuff. So i broke out my laptop so i can type better and lay this out for you step by step. here goes.

    From post #343 in this thread, there's the link to Grabber's script. it's right here:

    1. ON A PC, right click that link and choose SAVE LINK AS...

    2. in the Save As dialog box, confirm the file name shown is exactly "" and CHANGE THE FILE TYPE to ALL FILES (not the MScsv default)

    3. CONNECT your device to PC via USB LINK ONLY. (no need for WOSQI here)

    4. USE PC TO TRANSFER THE FILE to your device (usually shown as an E: drive) this will put it into your device's /media/internal file (the default location)

    5. EJECT the E: drive to disconnect USB link

    6. ON YOUR DEVICE, you MUST have Preware installed. (if not, you will need to put WOSQI and Novaterm drivers on your PC, so you can use them to install Preware. Search this forum for how to install WOSQI v4.6.0)

    7. USE PREWARE to OTA install the app WTERM.

    8. Open WTERM. You'll see a command line window. it should read "wterm@YOUR PHONE'S NAME:-$"

    9. Type the command "cd /media/internal" and enter.(notice the space after "cd"!!)(no quote marks) it should now show "wterm@YOUR PHONE's NAME:/media/internal$" (**remember to HOLD the shift key while typing periods and slashes)

    10. Type the command "./" (no quotes)

    11. you should see a blurb showing it's connecting to open ssl clients IMAP and SMTP. it is downloading the most current certs!

    12. Close out of WTERM.

    13. ON YOUR DEVICE, open Device Info app.

    14. Open Preferences, select Cert Mgr, click the icon for adding a new cert. You should see two, "googleimap and "googlesmtp, .pem" with the most recent date. (i just did this and see it's dated 8/22, which would be like cert #7!)

    15. Click each .pem file and trust them. Done!

    If you have any problems, specify what step # you're hung up on so someone can help further.

    good luck!!!
    I have tried all of these steps to resolve my Touchpad's mail problems but haven't gotten anywhere...everything works as described (except the file that gets downloaded on my computer is "" I just chop off the .txt) but then at Step 14. there are no new certifications.

    I think the problem is related to my general unawareness of many things that experts here know 'by heart'.

    I cannot find the ' /media/internal file '.

    In my hands, following the wonderfully explicit instructions results in the installation of the two .pem files (googleimpa.pem and googlesmtp.pem) into a folder on my Touchpad called ' sslcerts' ...which resides on what I would call the 'desktop' ? of the Touchpad...the list of files that shows up when I click on the Touchpad's icon in Internet Explorer.

    So have I done everything right but not put the two .pem files into a place that step 14. above can find them?

    Thanks. A lot (no sarcasm intended). For all the work all of you have done over the years. WebOS still rules (sort of). I cannot believe the mess iOS is...

    PS: I held out with my original month-of-launch Sprint Pre until about 18 months ago. I still miss it. My phone signature says 'No longer sent with my Palm Pre'.

Similar Threads

  1. Replies: 23
    Last Post: 09/04/2015, 12:51 PM
  2. "Requested encryption not supported by server"
    By freebirds in forum webOS Tips, Info & Resources
    Replies: 14
    Last Post: 02/28/2015, 08:33 AM
  3. Replies: 3
    Last Post: 11/10/2014, 05:31 AM
  4. CM9 Encryption Unsuccessful Touchpad Error
    By JackisBack in forum Android on webOS
    Replies: 6
    Last Post: 08/04/2012, 12:51 PM
  5. Can not access 128 encryption server (sercurity) error code 18
    By quedawg in forum Palm OS Devices & Apps
    Replies: 0
    Last Post: 02/06/2005, 03:16 PM

Posting Permissions