Results 1 to 11 of 11
Like Tree2Likes
  • 1 Post By Grabber5.0
  • 1 Post By Grabber5.0
  1.    #1  
    I keep getting an error when I try saving a picture from any website and when I try setting it as a wallpaper. I've used both the Isis browser and the default one, still get it. I even doctored my device and tried and still get the error. I just would like to be able to save some mtb wallpapers for my touchpad any thoughts?
    Smartphones: Nokia 5230 > Palm Pre 2 > Nokia 701 (returned) > HP Pre 3 > BB Z10 (save me from it) + HP Touchpad
    Cars: 1993 Subaru Impreza AWD > 2007 Saab 9-3 2.0T

    LinkedIn: Matthew Mers
    Twitter: MatthewMers
  2. #2  
    I get that sometimes... Usually it happens where the file url also has a query attached to it, like xx.jpg?56784390
  3. #3  
    You know, this got me to thinking. I have seen this many times, and as stated, it happens when the image was retrieved via a URL with parameters rather than a filename. Given that the image has already been downloaded, I suspect the issue is on trying to create the local file using the name from the URL, which is invalid for a local filename. I'm going to poke around the browser source code and see what I can find.
    Remy X likes this.
  4. #4  

    Correct... And in my experience, it always errors out after saving the file itself to Downloads, with the filename generated based on the URL.

    So if we could override the default behavior and give each file a proper extension before saving, it should go through to the right place. But I suspect that the downloader service (I forget what it's called) is making the wrong filenames in itself, and the browser is just complaining...
  5. #5  
    Ugh. Should have known it wouldn't be so easy. This functionality is buried in the browserserver, and the call through the browseradapter only contains the xy of the click, the save path (/media/internal in the case of 2.2.4), and the javascript callback function to call after saving the image. That means the browserserver would need to be patched, and we don't have the C++ source code for that. I looked through the openwebos source (it actually hands off the call to a class named BrowserPage - line 2630) and it uses a qfileinfo object to get the filename from the URL, which is (appears to be) a QT class that in this case just grabs the filename from the URL. Other than making sure the filename is unique, there is no test for validity - if no filename is returned or it fails to save, an error is reported and the request returns.

    TLDR: we can't fix it in current versions of webOS, but it could be fixed in Isis. In the meantime, a screenshot is the best you can do if it fails to save.
    Remy X likes this.
  6. #6  

    I was similarly disappointed while trying to track down and fix the "spellcheck in browser" bug, which would also involve patching the binary for which we don't entirely have source..

    But, for this particular issue here, I'm thinking that on error, rather than displaying an error popup, we could instead look for the last file to have been downloaded and compare the name to the initial url, then move, rename and display a "success" alert instead... I'm just guessing, but this should be loads easier than trying to fix the underlying problem
  7. #7  
    I don't think that will work, because the file does not ever get created in the destination folder. It either exists in cache, or needs to be downloaded again because it's not cached, and regardless, may not have been the last thing downloaded from the page. I am curious to know where the browser cache is though.

    -- Sent from my Palm Pre3 using Forums
  8. #8  
    I've been getting this error too, both in Web and Isis Web. I'll put it on the issue tracker on GitHub so I'll look into the issue in the coming days. That way it's at least fixed in Isis Web.
  9. #9  

    I often see the downloaded files in the downloads folder, where all of the PDFs get dropped. Adding a file extension makes it possible to view the contents, though I've only done this on my Pre+

    So I'm not saying that it succeeds every time, but that it works often enough for my fix to make a difference
  10. #10  
    I've been trying to recreate this but having a hard time finding a request that fails. Are you using a Touchpad or phone? Edit: I see you said Pre+ - what webOS version? On my 2.2.4 Pre2 they go to /media/internal
    Last edited by Grabber5.0; 06/24/2013 at 04:10 PM.
  11. #11  
    I believe it's the same path on 1.4, but I'll check... What I usually do is save the full screen image preview from the phone-style google image search, and that's where it errors out.

    I could then plug in to my computer and rename the file while doing the regular backups, but I could just as well use internalz if it was urgent...

Similar Threads

  1. Web photo saved photo?
    By gdgates in forum Palm Pre and Pre Plus
    Replies: 4
    Last Post: 08/03/2010, 11:52 AM
  2. Saving pics from web comes with an error?
    By nicoled985 in forum Palm Pre and Pre Plus
    Replies: 1
    Last Post: 06/25/2010, 02:16 PM
  3. Saving pictures from the web
    By adrianoftyriel in forum Palm OS Devices & Apps
    Replies: 2
    Last Post: 02/19/2007, 09:04 PM
  4. Saving Web Pages / Web Sites to Treo 650?
    By mbressman in forum Palm OS Devices & Apps
    Replies: 3
    Last Post: 07/29/2005, 12:09 PM
  5. Saving Ringtone Error
    By tarkwolf in forum Palm OS Devices & Apps
    Replies: 2
    Last Post: 08/12/2004, 10:56 AM

Posting Permissions