Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By TRoss
  1. TRoss's Avatar
    62 Posts
    Global Posts
    67 Global Posts
    Hi everyone, I haven't found a thread around here about this issue. You can read about it in this thread on the HP webOS forums here. To summarize, the problem is that for apparently no reason the Touchpad can no longer see any networks at all and the diagnostics app gives a warning for wifi with a Error Code 1000, which apparently means wifi cannot be turned on. Basically the radio gets stuck, I guess. That is part of what I am trying to figure out.

    The problem persists over a webOS Doctor visit and that only compounds the problem because it is extremely difficult to get past the activation scene without a network connection, so if you have this problem don't automatically think that doctoring the device cannot hurt, it makes things so much worse. This problem happened without warning at the beginning of March (it was working in my building downstairs and 9:30 and I went up to my office and tried to connect to the same network at 9:45 and it couldn't see any networks). HP eventually sent my device away and fixed it (it came back freshly doctored and with the same MAC address, for whatever that is worth) and it happened again in the same way about four days after I got it back, so they sent it away again. It just came back today and I haven't tried doing anything with it yet, I'm trying to finish another project I have going before I start messing with it again.

    Plus, waiting gives me an opportunity to consult the brain trust here in order to get some ideas how I might fix this problem in the future. Are there commands I could use in wTerm to try to jump start the wifi radio again? I assume since it keeps having the same MAC address that its not actually the radio but that its a software/hardware interface problem, so a software solution should fix it? This is an open-ended question, so hopefully some folks will want to throw ideas at it. Hopefully I won't have such a problem again, actually, but someone will and this thread might help.

    Thanks webOS Nation!
  2. TRoss's Avatar
    62 Posts
    Global Posts
    67 Global Posts
    I got my Touchpad back from HP last week (same MAC address) and took it on a trip this weekend, so I activated it on the hotel's wifi network and used it on that network for two days without incident. I turned off wifi before we left as the problem had previous presented after physically leaving the range of a network to which the device was currently connected. I turned on wifi when I got to the office this morning and it cannot turn on wifi and is giving me an Error Code 1000. Please, someone help me. I have been posting for weeks on this forum and on the HP forums and have not received a single response from anyone. Assume all the usual homebrew tools are available, what can try to do to make this work?

    I'm assuming they've been taking the device apart as the casing is now a bit sloppy. The screen regularly pops up slightly, making the home button feel depressed when its actually not, which can be fixed temporarily by pressing down hard on the screen around the home button. It never used to do that, so I'm guessing they've taken it apart and put it back together a few times.
    johnjaycee likes this.
  3. TRoss's Avatar
    62 Posts
    Global Posts
    67 Global Posts
    So I got wifi working again by using the Command Line in webOS Quick Install and typing:

    ifconfig eth0 down
    ifconfig eth0 up

    The networks immediately displayed on the device and I connected without any trouble. In the future, any ideas how to do this easily on device when the problem occurs? Could I make a simple app that executes a script and closes itself or something like that? I just want to be able to make this a painless fix for anyone who might have this problem in the future (including me).
  4. #4  
    Hi TRoss - sorry that no one was able to help you out. It looks like no-one really had an answer to offer up for you. Glad you got the issue resolved - albeit not completely fixed. Hopefully some dev or homebrewer can lend a hand with a patch or something (if possible).
  5. TRoss's Avatar
    62 Posts
    Global Posts
    67 Global Posts
    Thanks, I was just frustrated by the idea of having to send it in a third time without any promise it would be fixed permanently. Anyone know why wTerm doesn't recognize ifconfig?
  6. #6  
    Hi TRoss, I'm having the same problem.. I don't know if I did it right,but I got no go on the command line. I open quick install and use the linux command line is that right? Also is that a zero or an o at the end of etho? Do I need to be in usb or dev. mode I see all the wifi but can't connect. After seeing how dissatisfied you were with Best Buy, I decided to give it a try myself. I would be sending mine to Staples.
  7. #7  
    Thank you for posting about this. I actually was having this exact problem with my sister's HP Touchpad.

    I also used the method listed above, and actually only needed line 1. It immediately solved the problem, and I was able to connect to my mobile hotspot.

    Again, thanks to the OP!
  8. #8  
    Happy 2014 family, I have deleted some stuff off my tp. I want to know if that is a zero or an o? All so I have that useless acl along with the amazon app store. Would is be better if I backup and doctor? It sees the wifi,but will not connect. error 1000
  9. vgg
    vgg is offline
    vgg's Avatar
    83 Posts
    that should be a zero (eth0 is just the wifi interface) so the 2 command lines on post #3 above are just essentially switching it off and on again.

    happy new year


Tags for this Thread

Posting Permissions