Page 2 of 2 FirstFirst 12
Results 21 to 23 of 23
Like Tree4Likes
  1. #21  
    How do you tell if you are still in the windows prompt? The tablet is connected to novaterm, but there is no prompt, I've never used novaterm before so I'm not sure what sort of shell it uses.

    Also, it allows me to use the commands, like battery and to check the ID.
    Last edited by redno30; 11/12/2013 at 11:30 AM.
  2. #22  
    I have tried this (using the nova terminal), TP connected to PC, large USB icon displayed: Copied and pasted on the command line:

    luna-send -f -n 1 palm://com.palm.systemmanager/setDevicePasscode '{"passCode":"", "lockMode":"none"}'

    Response was: Command not found
    Any help would be appreciated
  3. #23  
    Quote Originally Posted by GMMan View Post
    I recently just got back my TouchPad, and since it had been a while since I used it, I completely forgot my password. After digging around the TP's filesystem, I came up with a solution.

    You must be able to access your TouchPad's shell. That means you need to have either Developer Mode enabled, or SSH for your TP is set up and Wi-Fi is on. To learn more about Developer Mode, see this page over at the HP webOS Developer Center. If you are using Developer Mode, you will need to have Novacom Drivers installed on your computer. Go here to get it.

    If you do not have Developer Mode enabled, you may use this Activation Bypass Guide to do it. A side effect of running the bypass tool is Novacom will be enabled, allowing you to follow the steps described below. Note that activation bypass has no adverse effects on a live system, as it would already be activated or bypassed if you can set a passcode on it.

    Please note that Exchange users whose device policies dictate they have a password will be unable to remove their passcodes regularly using this method.

    1. Open up a shell session. If you are using SSH, fire up your client and connect per normal. If you are using Novacom (Developer Mode), connect your TouchPad to your computer using the USB cable, and then open Novaterm by running
    C:\Program Files\Palm, Inc\terminal\novaterm.bat
    2. Enter the following:
    # luna-send -f -n 1 palm://com.palm.systemmanager/setDevicePasscode '{"passCode":"", "lockMode":"none"}'
    Do not enter the "#". It represents your shell prompt. (For those of you who have used luna-send before, you may have noticed the "-f" argument. It tells luna-send to format the output so it's more readable.) You should see the following:
        "returnValue": true
    3. Check that the passcode has been removed. Enter:
    # luna-send -f -n 1 palm://com.palm.systemmanager/getDeviceLockMode {}
    You should see something similar to the following:
        "returnValue": true,
        "subscribed": false,
        "lockMode": "none",
        "policyState": "active",
        "retriesLeft": 0
    If you see '"lockMode": "none"', that means your passcode has been successfully removed. You can now access your TouchPad by pressing the power or center button. If you still can't get in, hold the power and center button for a few seconds until the TouchPad resets type
    into your prompt. (Don't use hard reset, because filesystems won't be unmounted and you'll have to wait for fs-ck to finish on the restart.)

    Attachment 64587

    Other notes
    - Please do not use this to gain unauthorized access to other people's TouchPads. It is also not funny to change people's passcodes so that they can't access it, by breaking in and then setting it normally, unless it was April Fool's Day and you are certain that you can remove the passcode again.
    - This trick can be seen as both a good and bad thing. It's useful to be able to get rid of the passcode instead of remote wiping a TouchPad, but it is also sort of a security risk for all those who have Developer Mode enabled. Take what you will from it.
    - The commands were derived by combining luna-send and service calls from the Screen & Lock preference app. The calls can be found in the source file
    OMG THANK YOU!!! i have been locked out of my palm pix plus for a while now and the code worked for me once i removed the -f cause it is now their for me. but OMG THANK YOU!
Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions