Results 1 to 7 of 7
  1.    #1  
    Morning All,

    My brother received a new HP Touchpad for christmas yesterday, however so far we have been unable to get it to power on.

    I believe it was purchased a few months ago from new and has been sat in the box since then, so originally we thought the battery was dead.

    When we plug the touchpad in with the supplied charger (mains, not from PC) the home button flashes from left to right, and the device will not power on. We left the device charging for around 8 hours, however still no joy - screen is blank, home button still flashing.

    I myself also own a touchpad, so we have attempted to charge from my charger and my touchstone with the same result.

    Having read through several posts here I have attempted to reset the device by holding power+home for up to 2 mins, when i do this, the button stops flasing, goes blank, but then starts again shortly after. I have also attempted to get the device to go into USB mode by pressing and holding power+vol up, same result. There are also several other misc fixes I have tried such as holding power and pressing home button multiple times and holding power+up+home.

    Note i have attempted all these both while the device is charging and whilst it is unplugged. Also i think after holding all buttons and connecting to my PC, it showed up in device manager as QHSUSB_DLOAD - unknown device, and wasnt picked up by webos doctor.

    Sorry for the long post, but in anyone has any additonal ideas - help will be greatly appreciated.
  2. #2  
    Only thing I can suggest is to make sure you're hold the power button down long enough. To do a hard reset you have to hold the power and home button for 15 seconds - I do a slow count and it always seems right on 15 when it restarts.

    Good luck.
  3. #3  
    try downloading webosdoctor from here:
  4. #4  
    I had the same problem but in my case all it took was for me to play with the USB cord. It seems that the head, of the one that goes into the round thing, in the USB plug gets twisted or something.....I am afraid i am in ahuge hurry but I saw something else about it here when I had the probelm so I sort of moved mine around, in case it was loose, plugged it back in and it finally charged up just fine.

    it seems that it you let these empty right down, there can be problems gettig them to charge again but once u figure out in your case whats needed, it works.

    do a search on this and you will find a better descrtiption of what i am reffering to
  5. #5  
    My touchpad is new also and it does have a hard time turning on. I thought maybe it was just me but I have found to be very patient when turning off from a completely off state. It wakes up easily from hibernation. I hold the power button for a while until the HP starts to glow. When it gets to a full glow I push the power button again and it turns on.

    I would take any suggestions also!
  6.    #6  
    evening all,

    thanks for the responses

    quick update - I have been away for the past few days and decided to leave the device plugged in and charging whilst I was away.

    Having returned home this evening, I was surprised to find the touchpad setup screen on the device, now showing full battery.

    As per comments from ShelaghDB, I believe that if the device is fully drained, there can be issues getting it to power on/charge.

    Seems that a combination of resets and leaving the device plugged in for 48 hours+ resolved the issue.
  7. #7  
    There are issues with the TouchPads turning on initially if they are not charged, they seem to come uncharged, the operating system needs some power for it to turn on the first time. It took about an hour of charging for my touchpad to turn on the first time I tried. It also displayed a batter like this most of the time, along with the HP logo.

    HP EliteBook 8540W
    HP Touchpad 16GB - Zagg InvisibleShield - Skinomi Black Carbon Fiber Case
    Samsung Mesmerize - Commuter Case
    Samsung Galaxy Player 5.0 - recommend a case for me!

Posting Permissions