Results 1 to 3 of 3
  1.    #1  
    Hi, I tried to download 3 items of software from the App catalogue at once, and it's all gone wrong.
    TP works fine, but the 3 downloading items are showing as icons on the launcher with download circle's next to them. touching them launches software manager.
    Inside the App catalogue all three are showing as "Installing" (in green).

    And this has been the case since I started the downloads - a couple hours ago.

    Seems nothing I can do, software manager is pointless as I cannot delete them (and then try downloading one at a time)

    I don't want to go into device info and delete ALL my items of software.

    Is there any way I can either cancel these downloads, or delete just these 3 items?

    Any help would be most appreciated.
  2. alan sh's Avatar
    766 Posts
    Global Posts
    913 Global Posts
    I had this with Nova 2 - I just did a device restart and it then started the download again and worked.

  3. #3  
    Same here but I let it sit for along time and it eventually finished. If not that then a restart fixes it

    -- Sent from my Palm Veer using Forums

Posting Permissions