Results 1 to 3 of 3
  1. raffstyle's Avatar
    2 Posts
    Global Posts
    3 Global Posts

    Search other topics but cant find good answer to solve my problem, my wife using the touchpad last night, it was plugged to an extension cord while using it. she notice that its not charging up...even though the battery show that the TP is "charging" the % of the battery keeps dropping. so 10% left to the battery we decided not to use it and let it charge alone. when i check it at 4am battery was on 2% yet the "charging" icon still on. tried rebooting it but battery level still dropping.

    now my TP is dead.. everytime i tried to power it up. TP will show the big battery "charging" icon for few minutes then shut off.

    I want to order the dock to see if that will charge my TP properly.

    I will appreciate any help from this forum...

  2. #2  
    Hhmm.. this looks like a recent thread that may be closest to your own glitch?

    Rotary section of wall charger plug twisted and still locked into itself OK?

    Touchstone Dock might therefore be the way 'out'?

  3. #3  
    I had exactly the same problem that you have on HP Touchpad. the Battery Icon says charging - But it wont charge much when I hook it onto the wall charger and even leave it for 3 or 4 hours? Can you please let me know if you could make any progress with your problem? Did you solve your problem? That will help. Do you think the battery had gone dead?

Posting Permissions