Results 1 to 4 of 4
  1.    #1  
    Hi Fellow touchpad owners

    I am having an issue charging my touchpad. I have it plugged into AC adaptor and its all clicked in fine and used to work but now i am getting the message that there is insuffiecent voltage and that the touchpad may not charge properly.

    Any ideas? it is still charging but is taking the whole noght to do so. I have read other posts but most people either havent clicked the adaptor in properly etc. i have also tried 2 usb wires but still getting the same error message

    any help would be really appreciated

  2. #2  
    have you done a full reboot. Sounds like the barrel charger is on the fritz
  3. #3  
    Could you post the exact message you are getting.

    The Charging rate of the TouchPad is controlled by the state of the Data Pins on the Charger. Make sure that you are using a MicroUSB DATA Cable and not just a charger cable which may only have the +5V and Gnd terminals connected.

    If that fails, try another Barrel Charger. The TouchPad will not charge from Generic USB Chargers which will give you amessage saying "Insufficient CURRENT ......."
  4. sanjsrik's Avatar
    74 Posts
    Global Posts
    86 Global Posts
    I had this issue, there is a thread, not sure where exactly, but apparently, the original cords are the issue. I switched out my cord for the one I use for my HTC Evo 4g, and I haven't had an issue since charging my TouchPad.

Posting Permissions