Results 1 to 4 of 4
Like Tree1Likes
  1.    #1  
    Ahh this sucks...

    My Touchpad died on me while I was browsing and shut down as usual. The small circle bootscreen popped up spun around for awhile then the screen went black, normal.

    I plugged it in and hit the power button to see the battery icon and it never popped up. I assumed it was just "really dead" batterywise so I left it to charge for a few hours.

    I just picked up the TP and it hasnt charged and the screen still wont illuminate with any battery icons (the "wheres your charger" icon or the dead battery icon)

    I checked the outlets by plugging in my phone... I even switched outlets but still nothing.

    I even attempted to retart the TP with the center button power button trick and still nothing!

    Please tell me that there is a fix for this...
    Last edited by HelloNNNewman; 10/29/2011 at 08:52 PM.
  2.    #2  
    False alarm guys


    it took forever but it restarted after holding the center/power button.

    Ill update if it happens again... whew
  3. #3  
    my tp did this a while back, tried a different outlet and it worked. Scared me too.
    Dark Helmet: So, Lone Star, now you see that evil will always triumph because good is dumb.''`-Space Balls

    What doesn't kill you now, is probably a cyborg sent from the future to protect you.

  4. #4  
    <thread title updated>

Posting Permissions