Results 1 to 12 of 12
  1.    #1  
    I install the Xserver, XTerm and Xecutah
    but I don't see Xserver in the Xecutah, I can see the Xterm and utunta in the Xecutah

    basically, i want to run the command so i can run utunta without partition.
    mkfs.ext3 -F -b 1024 ubuntu.img 1900000
    but it said mkfs.ext3 not found.

    anyway to get the Xserver show in xecutah?
    I can see Xserver, xterm, xecutah under the download. and if i click on xserver, it said must use Xecutah to run.
  2. #2  
    If you have the Xecutah from the testing feeds, then it doesn't show the Xserver any more. Just select the Xterm in Xecutah and it'll start the Xserver with the Term in it.
  3.    #3  
    oic, thank you.
    but when i run the mkfs.ext3 comand
    it said not found.
    i thought this command come from xserver
  4. #4  
    I am having the same problem. I just installed xecutah today and I did not get it from testing feeds. I got if from Preware and it was the only one there, nothing to indicate it was not the official release. To see what I see when I open xecutah, please see my attached pic. I want to start an xserver so that I can then start the UbuntuChroot. Without the ability to start an xserver, there seems no way to start UbuntuChroot. I have installed xserver and can see the icon in applications. If I try to start it from the icon, it gives me a message saying I have to start it from xecutah. But it's just not there in xecutah. Can anyone help with this? It seems the absence of Xserver option in xecutah is making Ubuntu Chroot and Ubuntu itself impossible on the TP.
    Attached Images Attached Images
  5. #5  
    I'm nowhere near my touchpad at the moment so this is from memory.... as already been mentioned, these days the Xserver starts automatically, so if you start Xecutah and then start Xterm, the Xserver should be running and it should start the xterm.

    Problems creating the ext3 filesystem is unrelated to the xserver and xterm.

    In the case of the failing mkfs.ext3, are you following the instructions in this thread?

    Did you create your ubuntu.img image first, so that you can make a filesystem on it?
    Where? Is it on /media/cryptofs as described in the message thread (link above)?
  6. #6  
    Hi Alex thanks for the response.
    I have been attempting to put Ubuntu on my Touchpad using instructions I found here at precentral and at a wiki at web-os internals. (Sorry I'm not allowed to post links here yet).
    My problem is:
    - I need to have Ubuntu 11.04 Chroot running to use the method of these instuctions
    - In order to run Ubuntu 11.04 Chroot I need to launch a xserver from xecutah
    - xecutah isn't giving me the option to launch a xerver (see pic in my above post)

    xecutah IS showing options for starting xterm and Ubuntu 11.04 Chroot. The option for starting xterm works. But the option for starting Ubuntu 11.04 Chroot does not. It would appear that you have to explicitly start an xserver from xecutah before you can start Ubuntu 11.04 Chroot from xecutah. With no option to start an xserver from xecutah, you are up the proverbial creek.

    Does anyone have any ideas how to fix or work around this?
  7. #7  
    Quote Originally Posted by Len111 View Post
    xecutah IS showing options for starting xterm and Ubuntu 11.04 Chroot. The option for starting xterm works. But the option for starting Ubuntu 11.04 Chroot does not. It would appear that you have to explicitly start an xserver from xecutah before you can start Ubuntu 11.04 Chroot from xecutah.
    I think that was the old way (from about a month ago) where you had to explicitly start an Xserver. But now it is automatic. First this change appeared in the testing feeds, but I'm pretty sure that is now the default.

    The attachment looks fine to me.
    Similar to mine, except mine shows debian rather than ubuntu.

    Please tell me what happens if you select "Start Xterm" from the Xecutah screen.

    Does nothing happen at all?
    Do you get smoke and flames?
    Or does it start a terminal window?

    If it starts a terminal window, then that is your xterm - and you can't have an xterm without an xserver running.

    You can check the process is running as follows:

    ps aux | grep X
  8. #8  
    If I select "Start Xterm" it does start a terminal window with a linux prompt. That seems to be working OK. But if I select "Start Ubuntu 11.04 Chroot" I get nothing. Most of the stuff I am reading tells me that you have to start xserver before you can start Ubuntu 11.04 Chroot, so I am assuming the problem is there is no xserver for me to explicitly start. But I guess it is possible that xecutah does start xserver and then the opening of Ubuntu 11.04 Chroot fails for some other reason (maybe I got something wrong in following the instructions for creating the ubuntu partition, but everything seemed to go OK there). It's diffult to troubleshoot when xecutah just does nothing when I select "Start Ubuntu 11.04 Chroot"; there is no error message or anything.
  9. #9  
    In the X-Windows system, you aren't going to have a working xterm without a running Xserver.
    X Window System - Wikipedia, the free encyclopedia

    So it seems a little unlikely that the Xserver is the problem here.

    Did you decide to use a loopback device for ubuntu, or did you create a dedicated ext3 logical volume to mount at /media/ext3fs?
    What if you run these commands (in xterm)?

    ls -l /media/ext3fs/
    du -sh /media/ext3fs/*

    By the way, you might not see errors in starting ubuntu, the xterm or from the Xserver, but they might be logged somewhere... there are some log messages written to /tmp/xserver.log - I think it's 'normal' to get some messages about inet6 and missing font paths... these are probably nothing to worry about right now.
    Last edited by alex80386; 10/11/2011 at 01:16 AM.
  10. #10  
    Alex I created a dedicated ext3 logical volume to mount at /media/ext3fs.

    I tried the commands you posted in xterm and also in novaterm from my pc. I got the same thing each way. Here it is:

    root@LenHPTouchPad:/# ls -l /media/ext3fs/
    root@LenHPTouchPad:/# du -sh /media/ext3fs/*
    du: /media/ext3fs/*: No such file or directory

    I take it that means none of the ubuntu files that are supposed to be in /media/ext3fs are there?

    I also tried the command
    find -name ubun*

    and it gave me this result:

    Does that mean that the files that should have ended up in /media/ext3fs ended up in /media/cryptofs instead?

    Thanks again for your help.
  11. #11  
    Alex I have gone back through my entire set-up procedure and I am now pretty certain the problem is that the ext3fs partition is not mounting. I used these commands to ensure I have a folder at /media/ext3fs:
    mount -o remount,rw /
    mkdir -p /media/ext3fs

    When I attempt to mount the partition using the command:
    mount /dev/mapper/store-ext3fs /media/ext3fs

    I get:
    mount: mounting /dev/mapper/store-ext3fs on /media/ext3fs failed: Invalid argument

    I believe the "invalid argument" is telling me that it is not mounting.

    So now I am trying to figure out why.
  12. #12  
    My problem is now solved and I am able to launch Ubuntu 11.04 Chroot on my touchpad. I will outline what I did in case anyone else reads this and finds it of use.

    So I uninstalled Ubuntu 11.04 Chroot from the touchpad. Then I deleted the ext3fs partition that I had created and restored the space to my internal storage (there is a good procedure for deleting the ext3fs partition and restoring the internal storage in this forum written by above poster alex80386. Shouldn't be to hard to find it; sorry I still can't post links).

    Then I went about installing the ext3fs partition and Ubuntu 11.04 Chroot again. But this time I did 2 things differently. Instead of installing the ext3fs partition using the"re-partitioning by hand" method, I used the "WebOS Doctor" method. And instead of choosing a partition size of 8 GB, which I had done previously, I chose a partition size of 4 GB. Having done this I was able to follow through and mount the partition. I am pretty much a noob so I don't know if it was the things I did differently that did the trick or some other quirk of linus or webOs. But anyway I was then able to re-install Ubuntu 11.04 Chroot and launch it through xecutah without incident. Hope this may be of some use to someone else who stumbles along.

Posting Permissions