Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By traycer
  1.    #1  
    Hello, all! Brand new 32GB TouchPad owner here... just received mine from the fire sale this past Monday. I'm still not sure why I even need a tablet, but I couldn't pass up this deal.

    I'm a professional photographer, so one of the things I would like to do is use the TP as a portfolio. I loaded up the photos from my latest shoot as a test, and immediately noticed several things I didn't like about the standard photo viewer. Most of those issues have been discussed elsewhere (no sorting options, no labels, no slideshow settings, etc.) but I haven't been able to dig up any mention of this one problem I'm seeing.

    I resize my images to 1024 pixels on the long side to match the TP's display. I load them up into the gallery, and I can view them. However, I notice that horizontal images look nice and crisp, the way I expect them too. However, vertical images are slightly blurry. You may not notice if you don't have a sharp, well-focused photo to begin with, but it is definitely happening. I tried copying over larger images, but to no avail. Horizontal images always look great, and vertical images are fuzzy. I should try a square image to see what happens.

    Oh, I should mention that I am rotating the display depending on the orientation of the photo, as to maximize the viewing size. Thus a 1024-pixel tall image is shown 1024 pixels tall on the TP. There should be no resizing going on.

    Anyone else see this?
  2.    #2  
    Here's an example. I used the checkered background of X Windows to demonstrate that the gallery app is definitely messing around with something. The first is a screen capture of the X server itself (launched via Xecutah):

    The second is a screen capture of the above image as displayed by the photo gallery app:

    Both images are exactly 1024x768, so no resizing should be necessary. Yet it is obvious something is messing up. You can even see the difference on the keyboard. If I do the same test, but with a horizontal screen capture of the X server, it displays just fine. No resizing, no blurriness, etc.
  3. andyriot's Avatar
    36 Posts
    Global Posts
    230 Global Posts
    I would like to know this as well. I attempted to load up some previews of things I'm working on and they show up blurry and pixelated even when properly resized.
  4.    #4  
    Okay, I think I tracked down the problem. It seems that the photo app does not actually view the image file you give it! It will always generate a resized JPEG version, and then displays that! So even when I copied over 12-megapixel JPEGs and zoomed in on it, I was not seeing the original image pixels.

    If you look in /media/internal/.photosApp/Generated, you'll see a bunch of JPEGs in there with filenames like appScreenNail-++HhWVah81K_xuuF-my_cats.jpg and appGridThumbnail-++HhWVah81K_xuuF-my_cats.jpg. The "appGridThumbnail" file is the small thumbnail shown in the grid. The "appScreenNail" file, however, is actually the full-screen image. It appears that they are all sized to a width of 1024 pixels and a height of 768 pixels. This is fine for horizontal images, but when it runs across a vertical image, it shrinks the height down to 768 pixels. Then when you rotate the TP, it expands those 768 pixels back up to 1024 pixels. So you are losing quality because of the two resize operations and because of the lack of pixels.

    So that begs the question... are there any alternative photo gallery viewers (preferably free) that don't suck as much?
  5.    #5  
    Poked around a bit more, and I found the script that creates these thumbnails and proxy images. To fix this problem, open up a shell session on the TP and edit this file: /usr/palm/services/ About 20 lines down, you'll see a few variable declarations:

    var ScreenNail_WIDTH =1024;
    var ScreenNail_HEIGHT=768;
    var BigImg_WIDTH = 2048;
    var BigImg_HEIGHT= 1024;
    Change ScreenNail_WIDTH and ScreenNail_HEIGHT both to 1024. Or if you want to be able to zoom in to see more detail, set them to something like 2048. That determines the resized dimensions of the proxy images. The tradeoff for sharper, more detailed images and the ability to zoom in on photos is increased flash memory usage. Bigger files need more storage space.

    I don't know if there is a supported way to force the photo app to regenerate all the thumbnails and proxies, so I just deleted everything inside the /media/internal/.photosApp/Generated folder, restarted Luna (just in case), then fired up the photo viewer app again. It will churn through everything again the first time, but if you let it do its thing, you should then see properly-sized images.

    Man, I wonder what the developers were thinking when they wrote that piece of code...
    plgnply likes this.
  6. #6  
    That sounds interesting - sorry to be thick but how do you open up a shell session to change the script?
  7.    #7  
    Quote Originally Posted by sinewell View Post
    That sounds interesting - sorry to be thick but how do you open up a shell session to change the script?
    There are a few different ways, but my preferred method is to install the OpenSSH package from Preware, then login to my TP from my desktop. I'm a command-line sort of guy, and it is nice to login to the TP wherever it happens to be, as long as it has a reachable IP address.

    This assumes you are familiar with the shell environment, using vi, etc. The /usr filesystem is not available when you connect the TP as a USB drive (only the /media/internal filesystem is exported), so you can't edit the file directly on your desktop. Since I've not seen any ill effects with this change now for the past few days, I can look into turning this into a patch that one can simply download from Preware and install. I don't know anything about how to do that, however, so it might be a while before that happens.
  8. jdale's Avatar
    554 Posts
    Global Posts
    564 Global Posts
    Bumping this up a bit....

    The screenNail dimensions also limit the quality when you zoom in. I like 2048x2048, at that setting you get maximum quality when you zoom in all the way (assuming your original image was bigger than 1024x1024) but it does not take a lot longer.

    I also tried 4096x4096 but it still doesn't let you zoom to more than double size, and it takes longer. So not worth going beyond 2048x2048.

    I tried packaging this as a .patch file but it didn't work, not sure why.

    Oh, also I find the easiest way to edit these files is with Internalz.

Tags for this Thread

Posting Permissions