Results 1 to 8 of 8
  1.    #1  
    Hi guys,

    I have xterm and openssh installed on my touchpad. SSH works fine for me, except for X11 displays, using the -X option. I was wondering, is it even possible to get X11 displays forwarded onto the touchpad?
  2. #2  
    I've done it...just do export DISPLAY=:0.0 before your ssh -X command and it should work.
  3.    #3  
    Thanks man it works! Only thing is the X displays go under my keyboard, which doesn't go away... did you manage to fix that? Either make the screen smaller or keyboard go away?
  4. #4  
    Hold down the keyboard icon to get different keyboard size options. You could also try the --geometry option with X programs to specify the size of window you want.
  5.    #5  
    Alright, thanks very much for all the help!
  6. #6  
    is there a developer watching this thread?

    I am not always in a situation where I have a full vpn up on the touchpad. In those cases, I'd like to set up an ssh local port forwarder to tunnel through.

    this is easy and works well from the xterm. Now I'd like to write a simple webos app to do this (or any other linux script I'd like quick access to). Possible? Difficulty? I really don't have time to learn crazy tricks with the api and services, but am willing to learn enough to write wrappers to useful shell scripts.

    tia if anybody can point me in the right direction.
    : (){:|:&};:
  7. #7  

    I've been trying to figure out how to get X11-forwarding working from my ubuntu-desktop as an alternative to VNC and splashtop, and I just can't seem to figure it out. I am alas a bit too new to Linux to be able to see through the jungle, right now I'm stuck trying to figure out how to make openSSH (on the touchpad) play nice with SSH2 (on the PC).

    Do any of you know how to get this working?

    Splashtop worked fine (through wine) for viewing (eg. videos) but didn't let me actually do anything like clicking things etc. Damned shame

    Anyway, any and all help would be very much appreciated

    Thank you
  8. wang_r1w2's Avatar
    17 Posts
    Global Posts
    18 Global Posts
    Quote Originally Posted by lespedeza View Post
    I've done it...just do export DISPLAY=:0.0 before your ssh -X command and it should work.

    However, when I ssh'ed into my Macbook(running Snow Leopard) with xTerm with DISPLAY=:0.0 and with X forwarding(-X option), and then tried to start x, it displayed an error.

    I'm going to see if I can attach a screenshot.

    Can someone help me with this?

Posting Permissions