Results 1 to 13 of 13
  1.    #1  
    Well, I've somehow managed to break my browser.

    When I try to open a webpage I get the loading circle and the browser dims, then it'll stop loading for a sec, and then it will go back to the loading circle / dim. Repeat infinitely.

    Other apps seem to work fine. I was able to open the Facebook app, see recent statuses, and like one - so the internet connection still works.

    Since my device is not bricked and I don't want to lose apps/settings unnecessarily, I'd like to to be able to fix this without doing a restore/wipe of any kind (obviously only if possible)

    I'm not sure exactly what I did, so here's all the stuff I've been up to between when it was working and now.

    1) Installed OpenSSH
    2) Installed Joe and nano text editors
    3) Edited the /var/palm/event.d/mobi.optware.openssh file to allow for ssh passwords
    4) Edited /etc/hostname to change the hostname of the device

    5) found out the brower wasn't working

    6) returned /etc/hostname to "webos-device"
    7) Uninstalled openSSH

    still not working

    The built in browser in the facebook app won't load webpages (same problem). The body of emails won't load.
    Also, I can't seem to novacom into the device anymore.
    Before all I had to do was type novacom and it would connect
    Now it lists all the command line options for novacom.
    I'm not sure how to specify a device with novacom, but -l returns:
    matt@matt-laptop:~$ novacom -l
    51995 ee8ef36ffc78b08cf104608bf36aa6a7efc44733 usb topaz-linux
    Last edited by matthileo; 08/31/2011 at 02:45 AM.
  2. #2  
    seems to be an issue with the browser
  3.    #3  
    Quote Originally Posted by thetman View Post
    seems to be an issue with the browser
    Maybe, but how would I fix it?
  4.    #4  
    UPADTE: The device is playing absolutely no sounds whatsoever. I was able to open a document stored on /media/internal with the documents app, but I can't even open music or video files. attempting to do so results in an error.

    Also, what is the user/group that is supposed to own files in /media/internal/ (and what are the permissions supposed to be)
    Mine are all rwxrwxrwx root root
  5. #5  
    Looks like you might have to give the webOS Dr a try
  6.    #6  
    Quote Originally Posted by dirtyfingers View Post
    Looks like you might have to give the webOS Dr a try
    Did. It's not quite as bad as having to do a full restore on Android (although I still would have preferred to avoid it).

    [sent from my droid]
  7. #7  
    Revert the changes you made, working backward through your list.
  8. #8  
    Have you wiped the device yet?
  9. #9  
    I have been having the exact same issue. I first went through and uninstalled everything I had installed since I last noticed the browser working. No luck.

    Then I wiped it with WebOS Dr and began testing the browser after each app, patch, etc. Nothing was causing it that I could see (I thought it was OpenSSH as well, but that worked fine). then I updated ipkg-opt, installed sudo, and installed nano. Boom! Browser broken, openssh not working, etc.

    Since you didn't even install sudo, I am guessing it might be something to do with nano or with ncurses (which nano requires IIRC). I am trying another wipe and will check after each package install. Hell, it could be the ipkg-opt update. I will let you know what I find.
  10. #10  
    Any chance you installed sudo via ipkg-opt? That's what seems to be breaking mine.

    As soon as I run ipkg-opt install sudo the browser no longer works. I'm not seeing anything terribly helpful from the log files except for:
    [2302] webos-device user.warning BrowserServer: Certificate revocation list missing! /var/ssl/crl/crl-bundle.crl
    [2302] webos-device daemon.warning upstart: (02302/313823408) browserserver main process (6039) terminated with status 34

    The browser just keeps restarting and restarting. I am not familiar enough with linux or webos to have the slighest idea why installing sudo (and all of its files in /opt) would cause this. But it has been repeatable and quite predictable for me.
  11.    #11  
    Hmmm. I've got openssh and nano both installed again but this time I haven't installed sudo and everything is working fine.

    [sent from my droid]
  12. #12  
    Just in case anybody is still dealing with the issue, I found a fix that doesn't require using WebOS Doctor and you can even still use sudo.

    All you have to do is run the following to fix the permissions on /var and /var/lib:

    chmod 755 /var
    chmod 755 /var/lib

    Credit for finding the underlying problem should go to Stelloni (see thread below about sound issues caused by sudo):
  13. #13  
    This problem is sudo related somehow, because I had the same problem after installing it and rebooting. The permissions fix made the browser work again. Thanks!

    From what I'm reading sudo is basically useless in webOS anyway, because every update the /etc/passwd file is overwritten.

Tags for this Thread

Posting Permissions