Page 2 of 2 FirstFirst 12
Results 21 to 28 of 28
Like Tree3Likes
  1. #21  
    Quote Originally Posted by vwracer00 View Post
    I found the fix!! Go to "my computer" right click on the HP Touch Pad drive and click eject. Works for me!!
    this worked for me also on Windows 7 Pro 64
  2. #22  
    *delete* i just exited dev mode.. and did the safely remove hardware from winxp and didn't get the ouch that hurts icon. so exiting the dev mode worked for me. *delete*

    correction: that didn't fix it. my TP just ouched again!
    Last edited by ek9cusco; 09/16/2011 at 06:58 PM.
  3. #23  
    Any solutions for Ubuntu 11.04 users? I am not in dev mode. I did have novacomd running but I killed it before unplugging. Still got OWWW message.
  4. #24  
    I had the same unmounting issues. Everytime I left clicked, the device manager said the WebOS device was being used by another program. I came to realize the built in HP Cloud Drive (which automatically starts up on the sytem tray) was connecting to the Touchpad. I had to shut down the HP Cloud Drive before it would allow me to safely eject.
  5. #25  
    I have this issue too; tried it in Kubuntu 11.10 and Windows 7. Everytime I dismount my Touchpad Windows/Linux confirm that it is unmounted and now safeley to remove. But the Touchpad keeps complaining. oO
  6. #26  
    Haven't faced this problem until now.. *touchwood* but has anyone tried logging off Windows / Linux and then removed it..? It should work then, right..?
  7. TPRu's Avatar
    2 Posts
    I'm new to the forum and need some help.
    I have my TouchPad for a week now and try to get a solution for the unmounting issue.
    If I remove from the Taskbar I will get the "Ouch" message, if I go to "My computer" and try the "right click-eject" I get a warning that "the device is still busy".
    It's a Windows XP 32bit PC. I tried quickly at my office PC (Win XP 64bit) and there it worked.
    Is it possible that the USB drivers are different? I tried to update but they are obviously up to date.
    I would appreciate any suggestion...
  8. #28  
    I wrote a bash script that isn't elegant, but resolves the unmounting issue consistently. Note that the user running this script needs to be properly configured in /etc/sudoers (with the NOPASSWD option for this to work without having to plug in a password.) It should look like this in /etc/sudoers:

    <username>    ALL = NOPASSWD: /bin/umount, /usr/bin/eject
    And here's the script itself:

    # Script to cleanly unmount Touchpad or other WebOS device
    # Find the WebOS device
    DEVSTR=`ls -l /dev/disk/by-id | grep webOS`
    # Build the command to Unmount the Device
    CMD_UM=sudo\ umount\ /dev/${DEVSTR:(-3)}
    # Build the Command to Eject it.
    CMD_EJ=sudo\ eject\ /dev/${DEVSTR:(-3)}
    # Unmount, then Eject
    As I said, not elegant, but I hope that helps someone else. By setting the users up in sudoers with NOPASSWD, this can be a shortcut or a menu item.
    Last edited by Kotts; 01/11/2012 at 12:11 PM.
Page 2 of 2 FirstFirst 12

Posting Permissions