Results 1 to 4 of 4
  1. DroBoy's Avatar
    2 Posts
    Global Posts
    212 Global Posts
    I just got my TP 32GB and I can't download the new software. It goes all the way to unpacking then I get this error. "Unable to connect. Try again later". I already restarted the device. Any advice?
  2. #2  
    however, my tp was my second & my issue may have been different.

    I used the Butler service & they told me to be patient, it would eventually dl & install.

    I am not patient with tech stuff so I used the webos doctor to install 3.02. It was pretty easy, but the downside is you have to set up the device all over again.
  3. LuD
    LuD is offline
    LuD's Avatar
    21 Posts
    Follow this guide. I have tried the software update on three TouchPads, and haven't been successful once...

    This has worked 100%!
  4. Drag Bunt's Avatar
    2 Posts
    Global Posts
    3 Global Posts
    I was finally able to complete my upgrade today. I guess the servers aren't being hammered like they were yesterday.

Posting Permissions