Results 1 to 3 of 3
  1.    #1  
    Hey guys, I know there have been other threads like this but after searching through all of those and trying everything that people suggested, but my new 32 GB Touchpad still does not turn on.

    It was been charging for 3 and half to almost 4 hours now and I still do not have the HP logo pop up on the screen. The center button has been flashing back and forth the entire time as well.

    I have tried switching to my second charger from my 16 GB Touchpad and checking that both chargers are screwed in correctly like others have suggested but still does not work. I have even traded out USB cables, tried multiple outlets, tried holding down the power button 5 seconds, tried holding down the Home button + power button 15 seconds. Pretty much everything I could think of but still nothing.

    Oh yeah, I should also mention that my 16 GB Touchpad booted up perfectly fine with a few minutes of plugging it in so it seems the chargers are working.

    Any suggestions?
  2. #2  
    i had a stubborn one that didnt respond to multiple chargers. Finally got it to turn on by holing both the power and home button for almost 2 minutes.
  3.    #3  
    Ok thanks I will try that when I get home. I held them for about 30 seconds but I will try longer next time.

Posting Permissions