Results 1 to 5 of 5
  1.    #1  
    Hi - I just bought a touchpad a few days ago and it worked fine until I tried to turn it on this morning. Last night the battery was at about 70% and I plugged the unit into the charger. This morning the unit would not turn on and the power button shows nothing.

    I've seen the other "won't power on" threads and performing the reset with the power/center button hold usually seems to fix the problem. In my case the reset does not work, and when plugged in to the charger the center button light stays dark. The unit appears to be completely dead, and HP is having me send the unit back 'for repair'. Just wondering if anyone else has come across this issue, or if I just got a lemon.
  2. #2  
    Is it plugged into the charger when you are doing the reset? I had to DISCONNECT the charger when doing the power/home reset.
  3.    #3  
    I've tried reset both connected and disconnected to the charger...
  4. No1up's Avatar
    48 Posts
    Global Posts
    57 Global Posts
    I have the same problem... any news?
  5. satchmo82's Avatar
    90 Posts
    Global Posts
    91 Global Posts
    I had this issue the other day. Try holding Power + Center for abt 15 secs.

Posting Permissions