Results 1 to 12 of 12
  1.    #1  
    Hi there,

    I have now tried for a couple of days to use my laptop (T61 Thinkpad, ubuntu 10.04) to provide a WiFi connection for my HP Touchpad. I do not have WiFi here but connect using a UMTS-modem on the laptop, so I would like to share the laptops internet connection (I do not have a Pre.)

    I tried the setup with my Ipod Touch and it works flawlessly. Basically, I do what is described here:
    [gnome] How To: Share your Internet connection via WiFi in Intrepid - Ubuntu Forums

    The Touchpad does not show any sign of noticing the access point of the laptop. The Ipod Touch immediately hops on, which shows nicely in the system logs. So I think the reason must lie with the Touchpad. At home or at hotspots the Touchpad's WiFi works without a hitch.

    I also tried fiddling around using the strategies listed here, but did not get any further (Touchpad never showed any reaction):

    Has anyone been successful to share an internet connection, maybe using Windows, MAC etc? Maybe HP wants to force people to only use the Pre ... ?

    Any comments are appreciated :-) what bugs me most is that I cannot do the webOS OTA-update...

  2. #2  
    I have one but it's for windows.
    Connectify. It's a program that creates a hotspot.

    I'm not sure if touchpad supports ad-hoc and from what I saw that's what you're trying to do.
  3. #3  
    I found my touchpad won't use ad-hoc networks like your trying.

    I took the CIM from my USB UMTS-modem put it in a MiFi mobile hotspot and use it with the laptop and touchpad.
    actually liking it better than the ad-hoc solutions I had used up to this point.
    the MiFi is small making it easy to take with just the touchpad. I can use the MiFi with everything and up to 5 devices at once. By-by USB UMTS-modem.
    Last edited by abcdpeterson; 08/15/2011 at 09:45 AM. Reason: fix typing error
  4. ksevern's Avatar
    28 Posts
    Global Posts
    56 Global Posts
    I also use connectify. Had my HP mini connected to a secure wifi and simultaneously connecting to TP wirelessly. This is getting me through until I resolve satisfying the security requirements on that network. I've also used this to use my iPhone to connect via bluetooth to the Mini to the TP....
  5. #5  
    wouldn't you need two network adapters on the laptop to make this work?
  6. #6  
    Shameless plug, I know, but you might have more luck setting your wireless chip to AP mode: Tim Henry's Blog DIY Wireless Access Point
  7.    #7  
    @abcdpeterson&ksevern: if you are right about ad-hoc incompatibility of the TP that would indeed explain why my approach did not work. Shame that Apple-devices do not seem to have that problem.

    I now looked possibilities of a true access point ( and Connectify) but found out that this will probably not work with my WiFi card (Intel 4965AGN ) as it does not seem to support master mode.

    I might try fiddling with TP internals, maybe it leads to something. Otherwise I just have to wait until I have coverage again...

    Thanks for everybodys feedback.
  8. #8  
    I want to pair my touchpad up with my nokia E6 using joikuspot. Is there any chance that this feature can be added to the touchpad/webOS?
  9. #9  
    I finally received my Touchpad after the firesale on August 21st, and I haven't had any problem connecting the Wi-Fi through the free ICS on my Nexus One via T-Mobile. Actually while out having pizza tonight, I was browsing maps on the TouchPad, while the spouse was browsing on her iPad touch. I was impressed with the speed, almost as fast as the 802.11n at home. While the TouchPad has some very clever features, I think I've been spoiled by Gingerbread and it's apps, (especially Swype!) I was really appalled by the lack of configurability of WebOS, compared to GB. As far as HP goes, don't get me started. Other than firesales, NEVER AGAIN!!!! Biggest joke in the industry. I feel bad for all the people that have hitched their wagon to WebOS. I've been using Palm planners since they came out, and for their time, they worked great, but the future (at least to me) is Android. On the other hand, HP is dead to me. Another story for another time.
  10. cj-m's Avatar
    42 Posts
    Global Posts
    348 Global Posts
    Quote Originally Posted by ksevern View Post
    I also use connectify. Had my HP mini connected to a secure wifi and simultaneously connecting to TP wirelessly. This is getting me through until I resolve satisfying the security requirements on that network. I've also used this to use my iPhone to connect via bluetooth to the Mini to the TP....
    How are you doing this?

    I have my N900 tethering to my HP dv7 (with wireless on) and then i have connectify on and running (not pro vs). i am using the Access point, WPA2 - PSK option. The Touchpad sees and is connected to connectify but i cant do anything else beyond that. it wont download or access internet.

    what am i doing wrong?
  11. bitflung's Avatar
    8 Posts
    Global Posts
    11 Global Posts
    I stumbled on this link:

    It offers an IPK that can be installed using preware or webos-quick-install. I did not write this, all credit to the actual author (maintaining credit to the author is one reason why i'm linking to the post rather than directly to the file)

    This works for me: my touchpad is able to connect to the ad-hoc wifi access point created on my mobile phone. ?Here are the steps I have followed:
    1. Install preware (google it if you don't know how)
    2. run preware once, answer 'yes' when asked if you'd like to setup filetype associations (this allows preware to install IPK files you download via the standard browser on your device)
    3. follow the link provided above on your device - it displays a forum post with a direct link to the IPK file that you want to install
    4. copy and paste the direct IPK link into your touchpad browser's address bar and press enter
    5. preware will open up and offer to install the IPK, follow the very simple and short installation procedure it offers.
    6. reboot the touchpad (not certain this is needed, but i did this so i'm including it in my directions)
    7. TURN OFF YOUR WIFI on the touchpad - as i understand it, if the normal wifi control mechanism thinks it is in charge of your wifi settings, it will prevent the ad-hoc app from doing its job
    8. launch 'Ad-Hoc', a new app that was installed using preware in step 5
    9. enter in the SSID (name of your ad-hoc access point) and some valid DNS servers (i used google's public primary and secondary, and respectively)
    10. on your mobile phone, fire up your access point software (i used Joikuspot on my Nokia E7)
    11. when the access point is ready and the touchpad wifi is OFF, press 'start ad-hoc' in the 'Ad-Hoc' app on your touchpad.
    12. the 'Ad-Hoc' app reports the IP address you've got once you've connected. for me it took about 3/4 of a second. Joikuspot on my E7 (the 3G->wifi app i used) also beeps once indicating a connected user.
    13. profit! you're now online!

    The big caveat: i don't see any way to enable wifi security features on the touchpad using this 'Ad-Hoc' enabler. that's ok, since to the best of my knowledge only WEP is supported by the ad-hoc 3G->WiFi mobile phone softwares, and WEP is so weak you might as well leave it turned off.

    I for one am EXTREMELY grateful for the work done to get this feature running, and i'm so excited i'm posting this exact message in response to a number of unsatisfied requests for Ad-Hoc support on the touchpad.

  12. #12  
    FWIW, (not quite on point with op, but conversation seems to have expanded) no problems using my rooted EVO and wireless tether to get internet connection on the Touchpad.

Tags for this Thread

Posting Permissions